Tape measure - bug?

I’ve been creating some designs for bookcases for a client and use Sketch up to give me dimensions that I then transfer to a cut list for a wood merchant.

While using the tape measure along three points on a vertical line, the overall measurement is wrong by 1mm.

measuring between points 1 and 2 reads 18mm which is correct
measuring between points 2 and 3 reads 18mm which is correct
measuring between points 1 to 3 reads 35mm which is incorrect.

I will have to do this manually now to make sure it’s correct.

Without seeing your model my best guess would be that you have the Units set too coarse and there is a fraction of a millimeter error in your model.
If you have the display setting at 1mm then a fraction will default to a whole number. 17.5 will read as 18, but when you add 17.5 to 17.5 it will show correctly show 35.




You’re using SketchUp Free for this?

As Box asked, share your .skp file so we can see what you are working with. I expect a simple solution, not a bug.

1 Like

Tape measure - bug

Bug implies that there is something wrong with the tool itself. But then it seems that your way/precicion of displaying dimensions is not revealing your errors. Unfortunately. Better correct the geometry before going on with modeling.

Sorry, not supposed to shout here. Something utterly going wrong.

1 Like

I added a questionmark to the title because it is probably not a bug…

1 Like

For sure it isn’t a bug.

When this happens to me it’s usually a non-coplanar line that goes off in a different direction but looks correct in top/various views. It’s only when I change back to perspective I notice the weirdness.

Thanks for responding - I’ve uploaded the .skp file. Would be good to better understand where I’ve gone wrong. I’ve circled with the line tool where this occurs. Its basically two shelves on-top of one another and measured at the corner. both boards are 18mm thick, and should total 36mm but the reading gives 35. Much appreciated for exploring.


V2 3D.skp (220.2 KB)

As I mentioned, you have the Units set to a 0 amount, no decimal places. Change that in model Info on the right toolbar.
You also have a strange bit of geometry sticking out 1268940mm.
GIF 8-04-2022 10-17-25 PM

With a little more accuracy put in:

Ah, fantastic, thanks for explaining.

You should also turn off length snapping while you are there, it really only causes problem.
And look into using Groups and Components, it would make things much easier.
By the way, if this is work for a client you should be using Pro or at the very least the Shop version, Free is not licensed for commercial use.