Tag window - Column resizing bug

Hello SU-team,

Using SU for Mac, I got an issue with the Tag window, I can’t resize the width of the columns, specially the name column.
Very irritating.

Why? And when get this resolved?

Thank you.

1 Like

Point 1 - this is not a bug but a function of the Mac operating system (I believe).

Point 2 - this is a forum for users but you are addressing your complaint as if we were Trimble or SU developers.

It would be nice to be able to resize columns. It would be nice to be able to do all sorts of things. Experience to date suggests that it is either simply not possible or that it is too far down Trimble’s To Do list.

Simon all what you say doesn’t help me or anyone.

On the mac, it depends on the developer if a column can be widening or not. I develop from system 7 on the mac, I could always create a column what could widened and it depends on the developer. With the Obj-C and Swift Tables/List it is always available. BTW, I am sure it did work before. I will show you a screenshot.

I did get a personal message to put a tag with the name ‘bug’ in bug reports, if Trimble did not read this why should they add a ‘bug’ tag.
But I will send them a note too.

Your last comment is also strange. Your own words suggests that Trimble make incomplete software and you don’t need you to stand up for them. If this is your way to comment, please stay away from my requests. Otherwise, standup for the issues.Screenshot 2021-11-11 at 14.22.46

1 Like

use at own risk…

It would be nice if any of the columns could be resized, I think it isn’t like that in SketchUp because only the Name column has content that may change its width.

The problem with the Name column not resizing is a known issue, and being investigated. This shows some of the topics about the problem:


All the columns are user resizable in the Tags window of Layout. So it seems it’s quite possible.

It’s worth noting that there are two separate problems here. The columns have never been user resizable by dragging the column divider in the header: they should be.

The second problem is that the names column ceased resizing automatically to take up any extra room available. This bug was introduced in the latest update of 21. There may be a fix for this as described in this and several other threads, but it involves tinkering with some buried settings that may be a bit dangerous, and has not worked consistently for everyone.

This is a matter of the settings in the specific nib (NextStep Interface Builder) file for the panel, as @MikeWayzovski showed. It is possible to edit nib files, though I think sometimes an app can override behavior set by the nib. But as Mike correctly noted, you do so at your own risk, as an incorrect file can crash the UI. In any case, it is not a fixed or inevitable aspect of macOS itself.

Steve Jobs brought this very slick UI system to Apple when he returned from Next, and it continues to this day.

I did use this method with some other programs, or in the past to change my own NIB’s during tests so I don’t need to compile the whole thing; but the issue could come up that the system thinks that the app is compromised.

However, I won’t do that in SU, specially because I know it did working, so it, the SU code, did toggle the bit somewhere, and therefor it could reset the bit again even with the changed NIB or XIB.

But your suggestion was welcome.

And of course I’am happy to see that Trimble is working on that. TOP

BTW, in the beginning I did a site:// search with Google and found nothing, but I would have to search further than my nose since I saw the links about this topic.

That’s true, especially if you make the change before running the app for the first time. However, after the first run and quit I have replaced nibs in SketchUp without macOS complaining. If you try this, make sure to keep a copy of the original so you can restore it in case of trouble.

1 Like

Thanks Colin. This is an INCREDIBLY frustrating nuance (I’ve tried the json fix and it doesn’t work-- I’m on SU Pro 2021 using the latest version of Monterey (Big Sur also had same issue). It’s such a silly issue but one that impedes workflow significantly. Like having an awesome car with a missing tire.

1 Like

Try this:
Detach the Tag panel (move it in the middle off the viewport)
Drag the bottomright corner up and to the left until you see the scroll indicators.
Drag to the right.


I’ve noticed that also. You can’t individually adjust any of the column widths, but if you drag the window out wider the name column expands. I didn’t need to do your first step, though. Just drag it wider. Widening the whole stack when it is stuck to other windows also seems to work.

So this still exists as a problem in SU22. Please fix it asap? Not being able to widen the Tag column display would be a bug we could live with IF the default width allowed more than a few characters, but it doesnt. This is a fundamental problem that until fixed, makes serious use of SU on a mac almost untenable.


Very annoying situation.

1 Like

Thank you!!!

One thing I noticed about this fix, it relies on the horizontal scrollbar becoming visible, and for me, resizing the Tags panel would not become small enough for the scroll bar to appear.

But, when I docked Tags with Instructor, I was then able to resize both to a point where the Tags horizontal scrollbar did appear, and that did then fix the Name column. Didn’t every time though, sometimes the horizontal scrollbar still didn’t appear.

Yes, been trying to reproduce this a while, the only fix that worked for me more permanently was a .nib edit in Xcode…

Dare I ask when SU might fix this? Its bordering on a show stopper for Mac users.

1 Like

First rule of thumb when troublefixing in a screenshare, is to check the version someone is using.

[menu] SketchUp > About SketchUp

There is also an item called ‘Check for Updates’
What is the actual version you use?

This is a showstopper. I can’t believe this is a thing. It is such a basic UI faux pas. Speechless.