Tag Visibility changes navigating between scenes unexpectedly

I am observing that I set up a scene, I update the scene and save the file. The tag visibility settings are as required for that scene.

I set up another scene. I update the scene and save the file. The tag visibility settings are as required for that scene.

I navigate back to the first scene and the tags have changed so that when I view the first scene it shows components that I do not want.

Please can someone assist what am I doing wrong. I do not remember having this problem with other files.

Further when you right click the scene tab and it give you the option to update is that update teh same as going to the scenes menu and doing scene update.

TIA

Look at the Properties to Save and Properties to Update tick boxes. Is Tag visibility selected or is it unticked? If unticked, the scene doesn’t save the state of the tag visibility.

Share the .skp file and I expect it’ll be easier to give you guidance.

What version of SketchUp? Please complete your profile.

Tag Visibility is checked in properties to update.

I was not aware of a properties to save check list where would I locate that?

Thanks

In the lower half of the Scenes panel.

Yes that is also checked.

As I said, it would help us help you if you share the .skp file.

Yes I was just trying to find how / where to add the file.

If it’s not too large, just drag and drop the .skp file into a reply. If it’s too large, upload it to Drop Box and share the link.

Bike Store.skp (1.1 MB)

There you go.

First problem is incorrect tag usage. Untagged should ALWAYS be left active. ALL edges and faces should be created and left untagged. Only objects, groups and components, get tags.
Screenshot - 12_7_2021 , 10_27_09 AM

Result of fixing the incorrect tag usage:
Screenshot - 12_7_2021 , 10_27_59 AM

Note that the active tag cannot be turned off so if you make a tag active, it will be visible in the scene even if you change which one is active later. Leave Untagged as active at all times. It never needs to be made invisible. Assign tags to the groups and components in your model and then use the tag visibility to show or not show those parts of the model as appropriate for the scenes.

This is the root of your problems with tag visibility in the scenes.

https://help.sketchup.com/en/sketchup/controlling-visibility-tags

To control visibility with tags, first create tags in the Tags panel; then assign tags to selected objects in Entity Info . We strongly recommend assigning tags to objects (groups and components) – and not to entities (edges and faces).

By the way, I would suggest using LayOut for the dimensioning. Also, for elevations and plan view scenes, make sure you are selecting standard views so you can set a scale for the viewports in LayOut.

Ok I think I am getting somewhere now.

I only set active not to be untagged as a quick way to remove the untagged items which I was going to tag later. In the other files I had tagged everything before hence the issue did not arise.

I have rectified this and the problem seems to be resolved. Thank you very much.

Out of interest what/how did you create that warning dialogue box?

By the way I don’t think I have ever knowingly tagged anything other than a group or component.

Evidently you did some editing after changing the setting. If you are planning to remove any untagged entities after you’ve done the tagging, just turn off the visibility for the tags, do a Select All and hit Delete. Also remember to purge unused stuff via Window>Model Info>Statistics.

I used a plugin called Default Layer Geometry from Sketchucation. It’s usually one of the first things I run after open files I get from others.

well, keep in mind that if you create geometry with something other than Untagged active, that geometry will get the active tag. Also, when you explode objects they inherit the object’s tag. That can be very useful for exploding nested components/groups but it can lead to geometry getting tags. If you explode to raw geometry, the next thing to do while the geometry is selected is to rest to Untagged in Entity Info.