Survey points random shapes


#1

Hello

My name is James, I am trialing sketchup for my company. we do utility mapping and surveying - specifically interested in 3d models of below ground utilities.

I have a trial version loaded and have been playing for two weeks now, I have loaded a plug in (total station importer) and have loaded some .csv files, but I have come across a problem and I cant work out why it is happening.

I have two imported survey points from a manhole, the centre point and radius edge. I thought I would be able to pick the centre point with the circle tool and use the radius marker to give me a dimension - but it will not give me a circle. just a funny red shape>?

as you can slightly see point 21 and 22 should be centre and radius but i get this as a circle? even without trying to snap to the survey points I get the same thing further down the screen.

Does any body have an Idea?

regards
James


#2

Hi James,

An image of a model doesn’t help us much.

If you’re at liberty to share the file, you can attach it to your reply in this thread.
Note the forum has a 3MB file size limit.


#3

Or create a new model with only enough objects to illustrate the issue.

Also you should have the Instructor window open as you learn to use SketchUp.


#4

Hello Geo,

sharonlee 1.skp (105.1 KB)

Please see attached sketch up file, it has the problem shapes?


#5

Hello Dan, I have uploaded a full file with a .CSV already loaded into it - sharonlee1 is incorrect I have loaded bromhof 1 and with two scenes, plan overall and mh points. MH points is for the manhole centres and radius it will not allow me to draw a circle using the circle tool- that is when I get the random red shapes like the picture I uploaded last night.BROMHOF1.skp (136.2 KB)


#6

Your model is difficult to work with, if not impossible at all. Used modeling space is way too large, the guide points (in Bromhof group) closest to SketchUp’s system origin are over 280 km away.
This isn’t going to work.


#7

Hello James,

Click through the scenes in this copy of your model:
BROMHOF1_Fixed.skp (103.1 KB)

As @Wo3Dan said, the model was located a great distance from the World Origin.
SketchUp’s OpenGL rendering engine simply will not tolerate that.

Notice I’ve moved the model such that its western and southern extremities are located at x=0 and y=0 respectively and the lowest elevation point of model is located a z=0

The rectangular face below the model was made a Component and locked to avoid inadvertently moving it.
The edges of of the rectangle coincide with the north, south, east and west extremities of the model.

Navigation is difficult in a model comprised of nothing but Guide Points and Text.
This rectangle provides a reference plane and some geometry to infer to.


#8

Wow ok,

Great advice GEO

I have looked at BROMHOF1_FIXED and inserted the manholes and surprise it works with no problem.
I will try with the component face below and see how we go forward.

Also 1 more question - I have just tried to export Bromhof1_ fixed to .KMZ it is opening in North america, in a different place to last night, co-incidently both wrong points were picked up in South Africa?


Why does my KMZ export have the wrong location?
#9

In SketchUp, geo-locate your model before exporting. Click on the little drop pin in the lower left of the SketchUp window to do so.


#10

Hello Barry,

Just had a look at that? Is there not a more accurate and Automatic way, after-all there is survey data imbedded in the model? All of my snap points are survey derived?


#11

Of course a little custom Ruby command could be written. It depends upon the structure of the imported survey points, and can the one that you want to be the geo-origin be filtered from the rest ?

See the API UI::Command doc.