Suggestion/Help needed with Push-Pull tool

Hi. I am using SketchUp Pro 2021 on a macbook pro, and the push-pull tool won’t work when I tried to cut a hole on a rectangle to create a door frame.

I drew a rectangle with its base sitting along the X-axis and its height along the Z-axis (see below). I then created an offset, tried to cut a hole by using push-pull tool to remove the inner part, but it didn’t work. It only kept extending the inner part.

However, when I tried to create a door frame by first drawing from the bottom along X- and Y-axis, pulling up along the Z-axis, creating an offset, then using the push-pull tool to cut the hole, it works.

Does anyone know what is going on here and why is this happening? How can I resolve this matter?Thanks very much.

Share the .skp file so we can see exactly what you have going on.

From your description, I think you created a 2D rectangle, and then created (via the Offset tool) another 2D rectangle within the first rectangle. The entire drawing is still 2D at that point. To remove the “door” just select the interior rectangular face (single-click) and delete it. The Push-Pull tool isn’t relevant.