Suddenly can't open my classic license

I’ve received two different sets of serial numbers and authorization codes from Trimble for my Classic license in the past 5 months and neither are working as of this week. Help!

Any 2019 and 2020 licenses you have won’t work, because you have activated in 2021 already. If it is 2021 that you’re trying to add a license to, that will be the serial number that starts with WA-, and the matching authorization code ends with bf5.

Colin, Thanks for you response. I did upgrade my 2019 classic license to the 2021 version but even inputting the serial number beginning with WA- and the authorization code ending with bf5 gives me the “Oops” message. I was using the program as recently as the beginning of this week with no problem.

I tried your license on my Mac, and it worked ok. There is an issue on Windows that would show the symptoms you’re seeing. Is it Windows you’re trying to use?

Bit of trivia for you, your Mac license includes 37xxx in it, which meant 37,000-odd other people were using SketchUp before you. My SketchUp 5 license includes 29670, so I wasn’t that much earlier than you!

My number was 11460, that was somewhat around 2005, I think.
But that was when the licenses weren’t ‘agnostic’.
There might be a distinction between US / Can and the rest of the world, as well.

I’m running a 27" iMac. I just restarted my computer and still no luck. Thanks for the license trivia!

I will message you the license that works for me, in case there are any errors in the one you are trying.