Submenus hidden in top menu bar (screenshot)

virtualbox
vm

#1

Hello All, I just installed Sketchup Maker 2016 without problems, to evaluate Sketchup, and I appear to have an odd problem: the submenus in the top menu bar (yes the menu bar, not the toolbar) pop under the background. Here’s a screenshot (I hope!) that will clarify. I have tried resizing, and fiddling with OpenGL settings without success.

Would really appreciate any suggestions as to what I’m doing wrong, and any ideas on fixing it…

Thanks!

PS: I am running on a virtual box Windows 7 VM - I have never had UI problems before with this VM.


#2

I have the same issue… have you found a solution yet?


#3

Which version of SketchUp? Your profile doesn’t say. Did you install it correctly using Run as administrator? What graphics card is in your computer. “None” isn’t the correct answer. There must be something or you wouldn’t be able to see anything on screen.


#4

You very likely have created the virtual machine with 3D acceleration enabled. It seems VirtualBox’s 3D acceleration driver (that connects to the host’s graphics device) is still after many years unstable (and this independently from the operating systems inside/outside the VM, which may have very stable native hardware acceleration).

When you notice graphics glitches like menus not rendering, the display not updating when resizing the VM window or WebGL crashing, then it is worth a try to disable hardware acceleration:

  1. Shutdown the VM (unfortunately pause/hibernate is not enough; if you want to preserve the current state create a restore point)
  2. Select the VM → Change → Display → uncheck “activate 3D acceleration”
  3. Restart the VM

Is the issue gone? However then SketchUp uses CPU-only software rendering (only available in SU before 2017).


#5

Both users appear to be using VM. Hmmmm…


#6

DaveR: Yes, installed as admin. For what it’s worth, its Intel Graphics under the hood, but all that shows is “VirtualBox Graphics Adapter” on the VM.

Aerilius: Tried this, issue remains.


#7

As in right click and Run as administrator?


#8

Indeed


#9

@Aerilius OP here. Thanks for the suggestion about 3D graphics acceleration causing the issue. This fixed it for me. Odd, because I thought I had tried disabling it when I originally had the problem.


#10

@anondude808 Disabling 3D graphics accel. just now worked for me


#11

Doesn’t work for me unfortunately. I get the following error:
Sketchup was unable to initlialize OpenGL! Error: ChoosePixelFormat failed.

With this error popping up I can’t get into Sketchup to re-enable HW, so I have to uninstall and reinstall.


#12

I asked you this question before. Which version of SketchUp?


#13

That is unfortunate. In case it helps I also disabled 2D acceleration in
VirtualBox config. I did not stop to check different combinations of 2D
and 3D (en or |dis)-abled.


#14

Hi DaveR, it’s Sketchup 2016, v 16.1.1449. I can’t get 2017 to install atm (problem .NET dependencies).


#15

Hi, OK this worked. I didn’t read carefully… it’s not enough to disable 3d accel in Sketchup, have to do the same in Virtualbox! Working now! Thanks all!