Menu functions not working

#1

When I try to do something that involves a sub window (Section > Place Section Plane) or (Make Component > Create Component), the sub window does not appear, and I need to cancel out of the function.

Where might the sub window be hiding, and how do I get it back?

Windows 10, SU 2018 Pro 18.0.16975 64-bit.

0 Likes

#2

Have you changed your screen setup recently? The windows may be appearing outside of the window, thus not being visible.

I haven’t run into this myself but based on what others have written in the forum i think going to View > Toolbars > Reset can fix it.

2 Likes

#3

Another possible remedy is in the top menus…

Window > Preferences > Workspace > Reset Workspace

1 Like

#4

Hi Julia: Unfortunately that did not work . However, curiously, the Toolbars sub window did open, which is puzzling.

And Geo, that did not work either since that sequence opens a Sketchup Preferences sub window, and the same thing happens – I have to cancel out of the function to get back to the working model…

Among the functions that are not continuing (presumably due to a sub window) is the 3D text tool…
I’m running 2 monitors but don’t see anywhere on the monitor screens that the info is hiding.

I did just upgrade to a GEOForce GTX 1050 since the old GTX 560 was buggy in SU2018, so it might have something to do with that…

0 Likes

#5

How about going down to one monitor to try and get the “reset workspace” window up to reset it. Then go back to two monitors to see if it made a difference.

If there’s no luck with that, the only other thing I can think of is to repair the SketchUp installation. Your profile is incomplete, but I take it you are using Windows:
Right click the SketchUp installer file and choose “run as administrator”. When prompted choose “repair”. It won’t do any harm to try.

0 Likes

#6

Thanks, IanT!

Weirdness with the two monitors.

I had the right monitor as #1 and the left as #2. The subwindow did not pop up.

I switched the invdia display settings to drag the right one to the left, and now the subwindows pop up.

So at least that part is solved! I can just swap the cables and everything will work. Thanks to everyone for helping!

Cheers,

Steve

0 Likes

#7

So what I think happens is that the location of the sub window is remembered in the program – in this case I had the program open in the left window (monitor #1), and the sub window would open in the right (monitor #2).

This means when I changed the monitor configuration, and made #1 on the right, SU still placed the subwindow somewhere to the right of the main window, though there was no monitor space.

I only discovered this by changing the display settings for the nvidia card, dragging #1 back to the left, and then when I tried it again the sub windows popped up.

Ugh.

0 Likes

#8

In future if this happens,
go Window/Preferences (to get the focus on that dialog)
hit Alt and Shift together, then tap m followed by any arrow key, then without clicking any buttons move the mouse around until the Preferences dialog comes into view, once you have that you can go to the workspace tab and hit the reset workspace button and everything will be restored. No need to change cables.

1 Like