SU2018 is running too slow

Hi, it’s me again.

I just installed SU2018 so i can access the 3D Warehouse. I used to have 2016 and it’s working properly, but now 2018 is too slow, my model is only 9MB! Just opening the file take so much time already.

I have MAC OS X Yosemite and I still have around 500GB memory space.
What could be possibly wrong? Please help.

I am afraid to upgrade to High Sierra because something might go wrong with my other application and I’m more doomed. It’s so frustrating because I have a deadline today :frowning:

You can access the 3D Warehouse from a regular internet browser here:

Your Mac might be a bit old, but it’s hard to know unless you give specifics about it. There’s a possibility it’s simply not very fast, but it could be other things too. Go to the Apple menu (upper left) and select About this Mac. You’ll be shown a detailed list of your hardware and software, which you can share here for more insight.

Your 500 GB of available data storage doesn’t really have much impact on the apparent speed of an application. It sounds like you have an old Mac like I do. Mine is from 2009 and I’ve upgraded the OS as far as it will go. Newer versions of SketchUp (2017 and newer) do tend to be slower on my MacBook Pro because there’s not enough RAM for the graphics. The CPU isn’t working terribly hard but the graphics card is and it can’t keep up. I think of it as being like my son when he’s got some great new idea. His brain can be going at light speed but he often can’t get the words out fast enough.

It may be that it’s time to consider getting a new computer. Consider it part of the cost of doing business.

For today, I would suggest you use SU2016 and access components you want from the Warehouse via your browser like I described to you the other day. Or model the components yourself if you can.

Thank you both for your responses.

I cannot access the 3D Warehouse website either that’s why I installed SU2018 as suggested by you, Dave.

But I have accessed the 3D Warehouse using SU2018, but after an hour or two, it got really very slow :frowning:

So if I will use 2016 again, how can I access the 3D Warehouse then?

Sure you can. Just click here:

I can’t since yesterday.

Is that what you see in your internet browser? Are you using Safari?

Install Chrome and use it instead.

I expect you are probably adding loads of highly detailed components with lots of textures. Try switching the Face Style to Monochrome so your graphics card doesn’t have to process the textures and see if that helps. Also make sure Shadows are turned off.

Yes, I use Safari and that’s what I see in my internet browser.
Okay I will install Chrome. But I tried Firefox yesterday, it doesn’t work either. But let’s see with Chrome…

Yes, I tried purging, switching to monochrome, shadows and fog off, etc. All these I’ve read from the threads on this forum. But it is still very slow, in fact it stopped opening now.

Here’s what I haven’t tried yet:

  1. Install Chrome and try to open 3D Warehouse from there.
  2. Uninstall 2018 and reinstall again.
  3. Will use 2016 on my models but download models using 2018, then just copy it on my 2016 model (not sure if this is possible though).

I’ll let you guys know later what worked for me.
Thanks again!

That’s a sign of an ancient (by computer standards) internet browser. There are probably other web sites that won’t display correctly either.

This probably won’t help with the slow down you are seeing.

You would use Save as… and set the SketchUp version to 2016. Then in SU2016, import the component you saved.

Again, it’s getting to be time to be looking for a new computer.

FWIW, this is from the Hardware and Software requirements for SU 2018:

Although SketchUp can run–I’m running SU2019 on my old MacBook on an unsupported OS version, El Capitan–its performance can be less than optimal.

Yes, I’ve read that earlier too, that’s why I was thinking maybe I have to upgrade to High Sierra because SU2018 doesn’t support Mac Yosemite.

So just for update:

  1. I installed Chrome and I can now access the 3D Warehouse! Should have just done that yesterday instead of installing SU2018.
  2. Uninstalling and reinstalling SU2018 doesn’t make a difference, it is still slow. This is perhaps I am using an “ancient” Mac Yosemite, lol!

Now that I am working on SU2016, my model is still a bit slow (not as bad as in SU2018) so I also think there must be something wrong with the models I’ve downloaded even if the file size is just around 200-500KB.

Anyway, thank you very much for all the tips and help!

1 Like