Sketchup Pro 2021 & 3D Warehouse /Models

Just made an update to Pro 2021 version - and have a problem never had with previous versions: download from models from 3D Warehouse direct is not working! Downloading as an file is working - but even then, importing in my working model is not working! Nor opening that file and copy/paste to my model. Any of you having the same issue? Any ideas for solution? Thank you ina dvance!

Did you install the latest version using R-click/Run as Administrator on the downloaded installation .exe file?

If not, close SU, Layout and Style builder if any are running, then do that and when prompted select Repair.

If that doesn’t work, then I have no other ideas to suggest.

Thank you, John – meanwhile, as I am impatient, I’ve tried the old, certified procedure: “deinstall/install” :rofl: And it’s working! Thank you!

And did you use Run as Administrator on the re-install? If you didn’t, do it again using Run as Administrator, and choose Repair.

SU can get its permissions in a tangle if you don’t do this. Some people get away without it, many don’t.

I have a question why does sketchup slows down when downloading so many components?

There is a Mac issue where downloading one model into a large model can take a long time for some people. If I download the same model into the same large model, it’s instant. I’m still not sure what is different in the systems of people who see that problem.

MY laptop is not a Mac Pro I figured maybe that’s why but this also happened when I’m on my Windows laptop. I always thought it depended on the component and how much polygons it has and more you download in the model it gets worse.

It does get slower when there are more components in the scene already. My theory is that there is some amount of checking that goes on, to make sure the new model isn’t going to clash with any of the other models, but I’m still not sure why it then works quickly for me.

One idea to try is to download into a new document, take the original component and explode it. Then copy the parts you need into your working document, and make a new component from the parts. That new component is bound not to clash with the existing components, although it could have included subcomponents. But it’s worth a try, see if the overall time it takes to get something is lessened.

Yes. So it is best to take care.

thank you @Colin @Anssi since your’e a sage what would you suggest because I purchase this Mac just for this software.

It’s less obvious with my avatar, but I’m Sage too! Not that it means I will have a better answer than Anssi, but it is more my job to try and figure out what is going wrong.

If you would have the spare time I wouldn’t mind talking and doing a screen share, to try to find out what is different with your setup.

1 Like

haha @colin do I sense some kind of “hey I was here first” I would love the help but if you mean remotely? I have had my share of that and it’s been nothing but frustration. Thanks but no thanks for the screen sharing. I will take your advice and try what you had suggested though.

I wan’t planning to come over, I would connect to your Mac remotely, and be able to watch the problem happen, and try any ideas I think of.

No, I haven’t. I switched to MAC not long ago - have to find out “how to” first :wink: Will do in the next days - at the moment just happy it’s working since I have to finish something today :wink: Wish you a great day!

Then the whole ‘Run as Administrator’ thing is irrelevant.

1 Like

When will SketchUp take Heic Images

We don’t know. perhaps when more than 0.05% of users start to use them. I have never seen one.

Actually I’ve been taken pics from my phone and tried to upload it on sketchup but this is format that came up.

I don’t have an Iphone so I had to look it up - there seems to be free converters available to get images into the Jpeg or PNG format out of it.

A lot of people who use iPhone also use Mac, and Preview can open the HEIC files and save them as JPEG or PNG.