Extremely slow 3D Warehouse import

I recently updated to Sketchup Pro 2019. Since then, while accessing the 3D Warehouse, models take forever to import. They’re super small models that are taking 5-15 mins. I’ve uninstalled/re-installed and checked the wifi connection. Still no luck. Because I’m on deadlines, I’ve resorted to building in 2018 then opening it back up in 2019 to render with V-Ray. This isn’t great for work flow though!

Any suggestions would be appreciated. Thank you!

Operating System: macOS Mojave 10.14.3
SketchUp Pro 2019

Did you get the idea to download the models from 3D Warehouse in an external web browser and then import into SketchUp? I’d expect that to be as fast as your browser can download, unless it is an issue with the 3D Warehouse infrastructure or with the importer in SketchUp (usually only slow for huge complex models).

Is it with specific models or any model? Can you provide a link to a model?

Thanks for your response!

It happens with all models - complex or not. It also doesn’t seem to matter if they’re my personal models, or other others. In 2018, it takes seconds. Here’s the link to the model that just took 12 minutes to import:

As an experiment, go to Preferences>OpenGL and untick Use Fast Feedback. Any change?

1 Like

WOW!!! Totally fixed it!

Thank you!

1 Like

And only import was significantly slow? I’m surprised that OpenGL driver issues affect import (which takes rather place on the CPU), and expected they at least affect also viewing/orbiting performance.

Hello -

I’ve been having this same problem for more than a year now and have gotten in the habbit of downloading from 3D warehouse into a folder on my desktop, which is more-or-less instantaneous. But now, when I try importing the a downloaded component from my desktop in to my working file, it often takes a similar amount of time when compared to downloading it directly in to the working model from the 3D Warehouse. Very, very frustrating.

I tried DaveR’s suggestion about unticking Use Fast Feedback to no avail. I’ve also confirmed that my iCloud drive is turned off - a solution suggested in other threads.

It seems that many people using Mac’s are having this problem. Has a solution been found?

Thanks -

Doug

I have the same problem. On a Mac. It’s so extremely slow. Have tried the proposed sollutions, in vain. This is frustrating and time consuming…

Do you experience the same in an empty file? Where are you located?

1 Like

I’ve tried in a new file and than it goes very fast.

You might try purging unused stuff from your model. Window>Model Info>Statistics.

1 Like

Try this workaround, untill it is solved:
Open a new tab (empty model) download in that file,
Copy paste in the other (Cmd X/C, Cmd V)

1 Like

Thank you all for the tips!