Sketchup model slow on MacBook Pro 16" 2019

Hi guys!

I’m a relatively new SketchUp user and I need some insights/advice please.
I upgraded my laptop in June this year as I was using a 5 year old iMac previously; the specs of my laptop are:

Screen Shot 2020-12-05 at 8.27.16 pm

I have run into problems while working on a whole house 3D model which is currently sitting at 1.62GB. Since even before the file reached that size, the model has been crashing (with numerous bug reports submitted), freezing, ‘buffering’ and just overall lagging. For example, when I import an item from the 3D warehouse, or make some sort of change to the model like orbiting or changing the texture, the app ‘buffers’ for atleast 30 seconds at a time, which in turn affects my workflow :woozy_face:
This was happening on the SU 2020 version so I recently upgraded to SU 2021 and there has been no improvements. I have been working with pretty much all but the absolute necessary layers turned off, using a ‘quick’ style and only have 2 scenes. I would have ideally liked to do walk-through animations and rendering but with the current state that seems unattainable.
I’m not sure whether its the computer itself thats the issue (and whether I should be taking it back to Apple), the SU program is not compatible with the specs, the file is too large (or if it’s just me haha).

Any advice and insights is greatly appreciated! :slight_smile:

My latest “Whole house model” is about 8 megabytes. The only thing you can do is change your modelling habits. Nothing else can help you. There is no available Windows or Mac computer hardware that could run your model well, and supercomputers don’t run Windows or MacOS.
Throw away all the components you have downloaded from the 3D Warehouse. Purge your model.

2 Likes

This is huge! Extremely! As Anssi say, purge your modell. Go to Model Info>Statistic> Purge unused. Regularly.

Do not import directly to the modell. Download it separately into new file, examine, purge, derivate out unnecessary Tags(layers), materials, components, geometry… then you can insert to your main project.

Use optimized textures. Purge the materials regularly too.

If have not done yet: Go to View>Edge Style and untick the “Profiles” (Or use the style without Edge profiles)

2 Likes

I feel a little silly :sweat_smile: purging helped! I had no idea about that. Thank you to you both Anssi & Dezmo! :relaxed:

I was a bit categoric about 3D Warehouse content. But caution is important. Examine what you are importing, especially the face and edge counts. And do not try to model a forest with fully 3D tree models or a traffic jam with detailed 3D car models. I just recently examined a model that was a large apartment building with many stories. On one outer wall the modeller had placed three or four creeping plants. Deleting those cut off about 85% of the face/edge count of the whole model.

Also turn off View, Edge Style, Profiles. That will make working on the model be dramatically faster.

1 Like

:eyeglasses: ?
Repetition, the mother of knowledge! :wink:

What I do with huge models that needs to have a lot of textures and detailed components that are slowing down rendering is to use a style with as few bells and whistles as possible, use monochrome mode, etc to remove as much burden as possible for the graphic card.

I also create a style with the required settings for a nice render, even with shadows, etc.

Then I select the lighter style and create a scene that I rename Work. After that I select the heavier style to get the model in its full glory and create another scene that I rename Render. For both scenes, I make sure that the Camera settings are not memorized (uncheck the relevant box).

So, I can click on the Work scene tab to obtain a model that render quickly, allowing me to quickly orbit, pan and zoom to get the required view. Once done, I just click on the Render scene tab to see the model at its best.

For super heavy models, you can even use the Wireframe mode to speedup things.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.