Sketchup pro 2016 slow


#1

SketchUp pro has been unbearably slow for me in the last year since I purchase a brand new macbook pro.

Here are the specs. I need to get this fixed as it’s causing me to loose money!

OS X Yosemite Version 10.10.5
MacBook Pro (Retina, 15-inch, Mid 2015)
Processor 2.2 GHz Intel Core i7
Memory 16 GB 1600 MHz DDR3
Startup Disk Macintosh HD
Graphics Intel Iris Pro 1536 MB


#2

I don’t see anything in those specs that would specifically slow down SketchUp. So, some speculative questions:

Have you turned off hardware acceleration in the preferences? That is sure to make SU slow.

Have you got extensions that are loading down the machine, e.g. real-time renderer?

Have your models gotten large and complex? A large enough model will overwhelm any computer. A huge number of faces and edges (millions) will do it. Big numbers of large textures will do it. Turning on shadows can do it.


#3

@slbaumgartner - Thanks for the tip. I’ve turned off hardware acceleration which seems to help a little.

However it still unusably slow. Any other tips?


#4

what is slow? modeling tools or display output during screen transformations or… elaborate a little bit more descriptive.

Check content of affected model at “Window > Model Info > Statistics > Complete Model” and press “Purge”.

Unhide everything, switch on all layers, select all and copy’npaste to a new document.

Optimize your modeling techniques.

Buy a system with a dedicated graphics card (GeForce GT(X)), office systems with integrated/shared graphics sub-systems are no good for 3D modeling.