Mac 2021 w/ M1 chip running SU pro 2021.1.2 VERY SLOW

Hi there!

I am experiencing very slow speed when creating my landscape designs in 3D.

I have the 2021 MacBook Pro with the M1 chip and the newest version of Sketchup 2021.1.2. The designs I am doing start running very slow as I add more models from the 3D warehouse.

Does anyone have any tips or tricks that could help me experience less or no lagging when operating the software?

Assuming that you have a subscription license, why not upgrade to SU 2022, since it adds native support for Apple M1 chips?

You should see a big performance boost with SU running natively (and not through Rosetta 2 as SU 2021 does).

Thank you! I’ll give that a shot when I get home…

What kind of models are you importing from 3D Warehouse? It’s likely a high-poly or textured model that could be causing the slow downs. Do you have slow performance just modeling from a new file with no 3D Warehouse objects added?

No just with 3D warehouse objects

I can probably figure it out but just so I don’t screw it up, can anyone tell me how to update my 2021 Sketchup pro version?

You can leave 2021 there, and install 2022 as well. This will give you the Mac 2022 disk image:

There is a fix in 2022 that may help with downloading 3D Warehouse models into your model. When you have both versions installed, can you try downloading something into the same model in 2022, that would have been slow in 2021, and say how much time it took for each case?

Yessir, thank you

Sketchup 2022 is so much faster on my M1 chip than 2021. Each case took a matter of a couple of seconds. Thank you Sketchup Team for all your hard work.


That’s what we’re here for. Glad you got it working. Happy modeling.

So, there is another test you can do that would help…

Close SketchUp 2022 and go into Applications, SketchUp 2022, and Get Info on SketchUp. Set it to open with Rosetta.

Open SketchUp and do the 3D Warehouse test again. That will tell you if the speed up is because of the fix that we did, or if it’s because 2022 is running native M1.

After the test, uncheck the Rosetta box to get back to full speed.

Excellent! I’ll try that when I get home.

I’m having the same problem so upgraded to the Sketchup2022 version BUT Vray are having issues with the 2022 version of sketchup so I can’t render anything. They said " The problem you are facing turns out to be a bug with the V-Ray build for Sketchup 2022, its currently under review by our developers." Is there anything I can do?

Do you have the latest version of V-Ray?

Yes, that’s what they’ve said they have a problem with.

How does your M1 perform while orbiting a large model with shadows turned on?