SU2017 wont load Twilight Render 2


#1

The following error message keeps showing when I open up SU - am trying to use Twilight render 2, I have been using this for a couple of years and have just updated both SU and TR new versions and now they wont work together - any ideas?

Error: #<LoadError: dlopen(/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Twilight/TwilightLib2014.bundle, 9): no suitable image found. Did find:

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Twilight/TwilightLib2014.bundle: mach-o, but wrong architecture - /Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Twilight/TwilightLib2014.bundle>

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require’

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require’

/users/rebecca/library/application support/sketchup 2017/sketchup/plugins/twilight/twilight_start.rbs:10:in `’

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Twilight/twilight_loader.rb:2:in `eval’

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Twilight/twilight_loader.rb:2:in `require’

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Twilight/twilight_loader.rb:2:in `<top (required)>’

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight.rb:11:in `register_extension’

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight.rb:11:in `<top (required)>’

Error Loading File /Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight2/twilight2_loader.rb

Error: #<LoadError: cannot load such file – /Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight2/22/TwilightLibV2.so>

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require’

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require’

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight2/init_twilight.rb:22:in`module:TwilightLoader

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight2/init_twilight.rb:5:in `<top (required)>’

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require’

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require’

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight2/twilight2_loader.rb:2:in `<top (required)>’

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require’

/Volumes/SketchUp 2017 (English)/SketchUp 2017/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load’

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight2.rb:15:in `register_extension’

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight2.rb:15:in`module:TwilightLoader

/Users/rebecca/Library/Application Support/SketchUp 2017/SketchUp/Plugins/twilight2.rb:4:in `<top (required)>’


#2

I don’t use TR, so I’m just attempting to interpret the error messages you got. Here are some questions based on that (by the way, when you attach error reports such as this, please put a line with triple backticks before and after the report. That prevents the forum software from reformatting the report, which often causes it to drop portions):

  • what is the latest version of the TR extension? The error reports seem to say you have the 2014 version installed in SU 2017.
  • how did you install the extension? The report also is saying that the TwilightLib2014.bundle seems to be for a non-Intel architecture. There have been some previous reports of Sierra mysteriously failing to mark a newly installed bundle as Intel-compatible, which the OS takes to mean it is for the old Power-PC architecture. The simplest way to try to fix this is to remove the extension and try installing it again (there are other ways, but they get pretty propellor-beanie technical!).

#3

Hi, thank you for your response, unfortunately I’m not particular technical but am trying to understand as much as I can.

I have downloaded and deleted the programme at least 20 times but nothing seems to be happening, I will try again, The TR extension is brand new which I am downloading direct from twilight render website so I would assume that it is 2017. I did have twilight 2014 on their previously but am sure I have deleted all previous ones. Is there anyway I actually see if I have deleted it?


#4

Why don’t you try installing it from the Extension Warehouse and allow it to install properly?


#5

I have tried that too - when i click on it within the extension warehouse it opens up in my internet browsers for me to click and download and then it downloads into the arrow box at the top of my browsers so I double click on it to open, I have also tried, once downloaded, to go back into the extension warehouse and click install and then it opens up finder and I click on it that way. It then sits within the extension manager but doesn’t do anything else and comes up with that error message??