SU rotation problem


#1

I have been driving myself batty trying to figure out why I can’t get the pieces of my model to align when I assemble them. I think I have discovered a problem in SU. What do you think?

The model is @ x1000. dia = 136000mm.
the error circle is shown at the same scale.
So it is about 0.06% but enough that my top an bottom do not match up.
What I will try, as a work around, is to get the axis of everything aligned so that I do not have to rotate anything to assemble it. I thought I already tried that but I just tried too many things.
Also the first time I tried to document this the error circle was only 58mm dia. No idea why it increased
Also, I think the first time I did it the 180° rotation axis was on the error circle. This time it is way off.

the following pics are annotated.

bottom center 1 - axis aligned with center of model
bottom center 1
bottom center 2 - same view after 90° clockwise (from bottom view) rotation
bottom center 2
bottom center 3 - same view after 180° clockwise (from bottom view) rotation
bottom center 3
bottom center 4 - same view after 270° clockwise (from bottom view) rotation
bottom center 4

link to model file
https://drive.google.com/open?id=1PAUOzFQ6S9gt7KuOhz5F_f5NQmKdvUHc


#2

just add the skp here instead of on a locked google account…

john


#3

I didn’t think I could get it small enough.

Top no name.zip (2.6 MB)

It would seem like there is a problem with the center of the model. I placed marker lines on the edges and the model moves when rotated relative to those lines also.
But when I measure the radius from the CENTER of the model, all edges are the same size.
I am baffled.
I have another file with virtually the same model and it seems to rotate ok and another with a different model and it has a problem.


#4

another maybe associated issue. This may be as simple as it gets - 2 parts, 1 moving.
I create a large (say 150000mm) semi-circle using the 2 point arc on the red axis
I then make a 1000mm square from the center of the diameter on the green and blue axis.
I then pull the face of the square to the end of the diameter. When I get there the square is overhanging the diameter by about 45mm on the green axis.

end


#5

In answer to this second bit, the end segment in an arc drawn with the Arc tools is not perpendicular to the red axis (in this case) The end of the extrusion is perpendicular so it shouldn’t be surprising to see what you show in your last screen shot. In fact, there’d be a problem if it didn’t look like that.


#6

not following that.
If the extrusion is created by making a square on the green and blue axis at the origin then I should be able to pull it out as far as I want and it should still be on the red axis.
The diameter of the arc, since I used ends on the red axis is parallel/coincident to the red axis.
So if everything is square at the origin the end of the extrusion should be on the red axis. the right side of the extrusion obviously will not be on the arc.
The error is also consistent with the previous case


#7

bill, the first file has some very odd modelling…

I can’t figure how you arrived at it, and think that is it’s main issue…

the second, needs your skp to support your arguments…

it may be the ‘picnic’ bug…

john


#8

OK, where to I find an explanation of the PICNIC bug?
If I open a new file and create the 2nd model it is perfect.
If I create it in a file I am having a problem with it looks like what I posted.
Apparently there is something about that file.
I even deleted everything in that file and it still did it.
It is like the axis for the arc is different than the axis for the extrusion.
If I pull the square the other way it is clearly not on the same axis as the arc.
Maybe it has something to do with resetting the axis which I did in that file.
What am I missing???
If I reset the axis does it only function for that “TYPE” of object?

OK, I did a plain reset in that file and it works.
So the axis resetting to an object screws up everything else.
I’m not sure how I got there because I only did the axis rest AFTER I found a problem and tried to get the things lined up. Maybe somehow long ago I accidentally did a reset, but I have no recollection of it since I had to figure it out.

Is that the BUG?


#10

Bill, sorry, I was being inappropriately ‘geeky’…

PICNIC is an acronym for ‘Problem In Chair Not In Computer’…

john


#11

As @DaveR says, but you haven’t quite twigged yet, the first segment of a semicircular arc is NOT perpendicular to the axis, but at a slight angle from that.

Try drawing a semicircle with a modest number of segments - say 12.

Look at the first and last segments. They are neither perpendicular to the diameter, nor parallel to each other.

image

To get what you want, draw a circle, rotate it so that the midpoint of a segment lies on the red axis, draw the diameter, and delete half of the circle. What remains WILL have its first (half) segment perpendicular.

However, the pushpulled square DOES stay perpendicular to the red axis.


#12

OK, I have no idea what is happening. I occurred every time I did it this PM now it doesn’t and I am doing the exact same thing I did then.

I have an object in a file with other objects that is not aligned to an axis - I have no idea how it got that way.
How do I accurately straighten it to an axis without messing everything else up. Using a rotate move doesn’t insure that it is aligned - at least not the way I am doing it.

BTW, the group box it is in is not aligned either which is why I can’t snap it to the axis.

Also, John, as I have mentioned b4, what I have been talking about is NOT the segments on the arc…


#13

Bill R.skp (23.2 KB)

Does it happen with this file? It works fine for me.


#14

Sorry, I misunderstood that. Looking again at your image of the ‘overlap’ I see now that you mean the overhang at the left of the red axis, whereas I thought you were referring to the overhang of the right hand corner beyond the arc segment.

When I repeat your description, in SU 2018, I get this:
image

Which is what I expect.

In your model, I see that a R click on the axes shows Reset NOT greyed out.

Did you by accident Place or Move the axes? If you didn’t, why is Reset showing as an option on R click?


#15

How did you make the square? I made mine using the Rectangle tool, and tapping the R arrow key, to make sure the square was drawn perpendicular to the red axis. I expect DaveR did the same.

Ours both extrude exactly along the red axis. Since yours doesn’t it seems it was drawn slightly off square.

Like you, I’m puzzled how you did that. And also how you apparently moved your axes so that Reset is an option.


#16

apparently, I wasn’t zooming in close enough when I made lines, etc. and it didn’t get snapped to the right spot.
When I create things and intersect parts, pieces are often created that I can’t see. Often I can’t zoom in close enough to find the minute pieces, then they create an issue when I try to verify integrity.
As I said, when I did it on a clean file it worked fine, They I tried redoing it on a “bad” file and it also worked - I have no clue. But I am redoing one part cause I can’t seem to get it straight. Tried everything that I am aware of.
thanks


#17

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.