Rotate function in online sketchup 2023 behaving erratically

I have a lot of angled parts on my ‘model’ which I always used to make on cardinal planes before using the rotate roundel/compass to orientate them into position. On my old version of sketchup this worked fine, in fact a wee sentence would often pop up telling you that you were lined up with the green red or blue axes. Trying to do this on the free online version is a total nightmare. The black protractor bezel now jumps about all over the place, behaving like its sat on a 3D corner even when it’s in the centre of a 'cross-haired circle! Nothing stops this, it’s totally random

What’s going on here, just another Sketchup 'peccadillo?

I don’t see a difference in behavior with the web version and the desktop version. Can you show a simple example model that behaves strangely?

It isn’t clear how you import a model onto this page. This is DEFINATELY a ‘bug’ (S/U themselves have asked folk to notify them of these kind of ANTICIPATED ‘teething problems’ on this very forum!).

Anyway, after a lot of cursing I’ve found a solution: create a ‘centre of rotation’ (a simple roundel on a stem - looks like an umbrella) make it a group and then drag its tip to the pivot point of your choice. It always works first time, but after that sketchup spits the dummy until you move the ‘umbrella’ away and re-position it …then it works again. Try a second rotation without moving the brolly and it all goes belly up again. And yadda-yadda.

If anybody can show me how to get the model into this forum I’ll gladly drop it in.

indeed. but right now, Colin can’t reproduce it, neither can I, unless we didn’t understand what you meant?
could you perhaps do a screencapture (video) of what you’re talking about ? so we can try on our side ?

download it. then simply drag it in the answer box. if it’s more than 16mb use a file transfer service.

Body shell re-profiled for thinner 3D print (1).skp (1.8 MB)

You should be able to see the wee ‘brolly’ in this download? Inexplicably, the pivot point at the articulation of the arm/shoulder seems to behave itself, but that big white cam has been a major problem all afternoon.

As I say, this was never an issue in the past; I’d just drop the rotate icon on the desired face and job’s a good un. The ’ brolly’ only really came into play if the ‘target’ was small or hidden inside another feature.

Doubtless it’ll work okay for you guys, but it’s been the cause of major ‘frustrations’ and delays+++ today, particularly the tedium of not being able to work on cardinal planes and having to build everything at an angle.

Never seen so many pink extensions!

I’m still not clear on what’s wrong, hence the screen recording…

I deleted the extra bit, used the rotate tool, and it rotates.
have you tried first placing your cursor on the nearby face and pressing the down arrow ? it’ll force the rotation on that plane (and make it pink)

beyond that, I don’t understand the issue. please show us.

You’re a total star! No, I’ve never seen that ‘trick’ before.

Cheers.

1 Like

You could halve your work by using components instead of groups.

Thank you to @ateliernab for narrowing down the problem.

1 Like

I used to; just found the other option quicker.

At least nobody has suggested working in layers…OMG what fun that was!!!

Yeah, fantastic.

1 Like