SU Make 2017- Can not manually enter dimensions for resizing

sketchup

#1

I have been using sketch make 2017 for modeling woodwork.

Anyway, I was using the program today with no issues at all and drawing a bathroom vanity/ linen cabinet. I had no problems at all when I would select the rectangle tool and drag out a corner. Then, without changing any tools, I type the dimensions (ex: 26, 21) and hit “enter” and the rectangle size to exactly what I need.

Ok, so this was all well and good and working fine…

a few hours later I go back to my computer to try and draw up a table.

This time however, any time I make a rectangle or even use the measuring tape ruler, I can not manually change to precise measurements. I can type all I want, without selecting anything else, and nothing happens.

When I draw a rectangle and go to type, down in the dimensions box I see a pop up with red writing that says “constraints not appropriate at this time”

Just to do a test, I drew whatever size rectangle I dragged out. Then I tried to push pull and type the value I wanted the face to move. Nothing.

It seems like I went from a normal working program to completely unusable. Should I just delete and reload? This is very frustrating.

More of a rant than anything… Since I’ve been using sketchup Make 17 for the last couple of days… I find it extremely annoying to not be able to select any of the dimensions in the dimension window! ex:

I draw a rectangle and it says 24", 48 31/32"

In the past when using my MacBook pro, I would simply click into the dimension box and highlight only on the axis value that required editing. So in this example I would highlight the 48 31/21" only, and retype as 48. It was quick, there was no need to really pay any more attention to the values if they were correct which I could visually see immediately.

I find that with SU make 17 you have to type the full X,Y value in. Which also means I need to pay extra attention to which value comes first so that my shape is drawn the correct direction, and I need to remember all of the values that were already correct + the values I needed to change because the second you begin typing they disappear from view.

I guess what I am saying is this is just making using this program far slower than it already was.

perhaps my application is a bit different… But when drawing a custom kitchen where doors from cabinet to cabinet are different sizes as is all of the casework, making components doesn’t save you any time, the last thing I needed was for snapping rectangles quickly to become more of a chore. Especially drawing in stile & rail components, reveals, etc. across an entire kitchen model that are precise to take a cut list from.


#2

What you describe is very odd.

But there are two things that raise a warning flag for me in what you say:

You should NEVER click in the Measurement box. If it is appropriate to make an input there, it just accepts your keystrokes WITHOUT you clicking in it.

You don’t have to do this in SU 2017, just as you didn’t have to in earlier versions. Suppose you drag your mouse to make a rectangle and one dimension is correct, perhaps because you were able to inference to a known size, but the other isn’t right, say 24", 48 31/32" as in your example. You want the second dimension to be an exact 48". Then WITHOUT clicking in the Measurement box just type , 48 (that’s comma, 48). Or if it was the other way round, you wanted the 24 to have been 23, then type 23, (that’s 23 comma).

But it’s odd that the behaviour changed,

Are you sure nothing else did?

And if you used to use Mac, are you aware that to install Sketchup properly (whether 2017 or earlier) on Windows you MUST start the install program using ‘Run as Administrator’. If you didn’t do that, weird things can happen because SU can’t otherwise get permission to write to the files and folders it needs to, to work properly.

If you didn’t do that, you can re-run the installer using Run as Administrator, and choose Repair.

That might fix your problem, if it isn’t caused by your clicking in the Measurement box.


#3

Hi John,

Indeed, I found that out while trying to trouble shoot this and reading other posts/ responses. I’m not really sure, but on sketchup 8 which is loaded on my MacBook pro, it allows me to click and highlight right where I want to edit the values. I just assumed ever since I started using it that this was the way to do it. I’ve pulled multiple cut lists straight from drawings I’ve done this way and everything was always dead on accurate in the finished build.

Man, your second point is a GOD SEND! AH HA! that will certainly make dimensioning a bit smoother. I didn’t know that’s all it was so I was literally typing both axis values and hating my life.

I have not been on a pc platform in almost 10 years. I recently switched back because the software I plan to move to in the future (cabinet vision) runs on a pc platform. But that’s a ways away because it costs $8-12k

So no, I did not run the install from the Run as Admin. I basically just downloaded it from the website and went through the prompts to load it. I will try doing as you suggested and see if that clears up the problem. Otherwise I’ll just uninstall and reinstall from the Run as Admin like you said.

With this new version, I did first try to click and highlight as I had always done on my mac and found out that I couldn’t get the cursor to pop up. Then I just tried typing values and it worked so that’s how I had been doing my drawings last night and today.

Will stay posted and update. Hope it works.

Update: Well, I had high hopes, but it didn’t wish to cooperate. I’m going to just uninstall and then reinstall from run admin as you said. Hope that fixes it.


#4

Interesting,

I tried to run a test of the program right from the SUM2017 app. I’m running windows 10 home on this new laptop I bought. Could this be the problem? In the test prompt it is showing this program is designed to run from windows 8 under its list of compatible OS. Am I understanding this correctly?

I did a full uninstall of the program, and then reinstalled using run admin. Same problem.

“constraints not appropriate at this time”


#5

Sorry to hear that reinstalling didn’t fix things.

SU 2017 runs fine in Win 10, PROVIDED that the stricter hardware, graphics driver and installed .NET and other Microsoft prerequisites are met.

I wonder if a Windows update might have affected the graphics driver?

I’m getting out of my depth here, and don’t currently have a Windows machine that will run SU 2017 (I use it now on an iMac).

Have you tried all the troubleshooting tips on the SU Help site? It gives a link to this forum post. There’s a whole list of things that have to be just right for it to install.


#6

Did you enable SketchUp to ‘always fix my problems’ under Preferences>General ? It is possible that you are ‘interfering’ SketchUp’s inference system by forcing correct dimensions in the vcb. Not the dimensions are conflicting but the ‘origin’ or the ‘endpoints’ of the rectangle or line that you drew. SketchUp has no ‘object-snap’ but has an ‘intelligent’ behavior which is best controlled with the inference-system.
The highlighted VCB is highlighted because you are still in ‘edit’ mode , not because you ‘clicked’ in .


#7

This topic was automatically closed after 91 days. New replies are no longer allowed.