SU crashes with OpenGL error


#1

I’m using SU Pro 2015 on an Alien x51 Windows 7 system with 16GB RAM, an i7 3.4 Ghz, NVIDIA GTX 760 and dual monitors (Dell U2711 in 2560x1440 and Samsung 4k in 3840x2160). Lately (after the maintenance update), the application crashes every few minutes with an OpenGL. This happens even with very simple models. Also, now the 3D mouse is pretty much non-responsive and SU is generally very sluggish. When I first upgraded from 2014 Pro to 2015 (same hardware setup) everything was working OK. Any ideas and help much appreciated.


#2

Is your Nvidia driver up to date?
Is the Nvidia the only graphics card in your computer (is there an integrated Intel chip on your motherboard or in your CPU)?

Anssi


#3

Yes, it’s the newest version of the driver (9.18.13.4725 from 1/9/2015). Also, I disabled the internal Intel Graphics driver and set SU to use the 3D settings of the NVIDIA processor. The exact OpenGL message is: “Request for more GPU memory than is available.”

Didn’t have any response or crash issues with the same hardware in the past.


#4

You have a rather large amount of screen real estate. Is there a difference in which monitor SketchUp is running?

Anssi


#5

I haven’t swapped them yet, but I will do to see it that helps. It’s a bit confusing that everything had worked just fine before and now something is causing these crashes.


#6

Anssi,

I’m closing in on the problem. It seems that if I keep the SU window size to less than 3/4 width on the 4k monitor, the sluggish response disappears and the 3D mouse starts working again fine. So it must be related to the screen real estate using up the RAM on the graphics card (only 1.5 GB) and than having to employ the shared video RAM.


#7

we have develped a free support tool for SU v2014/2015 f. Windows which enables to configure the texture raster size used, try if decreasing the size helps.

no installation, no malware, no spyware of course,


#8

This worked for me.
http://help.sketchup.com/en/article/3000055