SU 2018 no internet connection error

This issue was mentioned already - but I got this Problems since a few month now. At first I ignored it and used the 3D Warehouse in the browser. However now I need my extensions and they don’t run either.
Problem: SU2018 has no internet Connection.

I and my Admin we tried everything that is mentioned on the net.
To sum it up

  • SU2018 pro is the only Programme that has this issue
  • SU2018 is in the list of free access in the security settings
  • the same Problem when online via router or build in simcard - so not a Problem of the router
  • Firewall completely shut down - same Problem
  • same difference if using Chrome or Edge as standard browser
  • latest updates on windows and browser are made
  • repair install of SU2018 - was one of the first things
  • it runs on a single Laptop and worked there for years.

Could it be a Problem with the trimble server?

Any other helpful advice?

Thank you in advance.

I’ve edited the post title and shifted to Technical Problems.

I have no idea, but I did find this:

The old topic talks about the right thing, but is referring to old values for the setting. First, the not seeing Internet at all is not the same problem as there was recently where the 3D Warehouse window contents were empty. For people to see that issue, they absolutely did have to be online. What you’re seeing is that the online test is failing.

I have a theory about that, which you could help test. In older versions of SketchUp there is an i18n.dat, that amongst other things holds the URL that is used to test if there is Internet. The entry in the file looks like this:

ONLINE_TEST_URL=http://www.google.com/ncr

It could be that your network has security settings that prevent applications from accessing an HTTP URL. So, edit that entry and change the value to be https://www.google.com

If that doesn’t work, perhaps Google is blocked. Try https://www.bing.com instead.

The file to edit is in here:

C:\Program Files\SketchUp\SketchUp 2018\Resources\en-US

You may find that you can’t edit and save in that location, but copying the file to your desktop, doing the edit, and copy/replace it back in the right folder, should work. You may need to enter an admin password while doing the replace.

The file is a text file, Notepad can edit it.

Please let me know if making that URL be https instead of http does help.

2 Likes

Thank you for your hint.

I changed it to

[ONLINE CHECK]
ONLINE_TEST_URL=https://www.bing.com/ncr

but neither https://google nor https//:bing made any difference

I made the change in the [resources] [en-US] and [de] folder. But unfortunately no change.

Did you restart SketchUp after making the change?

The ncr is an old Google redirect mechanism. I would not include it in the URL.

Closing SketchUp before making the change would be a good idea. Then open SketchUp again after having saved the new file.

The problem is not the internet connection ‘an sich’.
It just takes to long.
Over 30 hubs have to be taken.

Thanks but of course I closed SU and restarted after the change.

Yes I did

THANK YOU very much - this helped!!!

This morning I removed the /NCR and now it works again.

Qu es el NCR también me pasa pasa este inconveniente y no eh podido arreglarlo

Hi.
I have the same problem with internet connection since a few month.
Using SketchUp Pro 2018 on Mac Book Pro / OS 11.14 (Big Sur)
Is there also a way to solve the problem by changing the URL.
And where can i find it?
Best regards

Here’s a post I did for someone else using 2018 on Mac, and it appears to have solved the problem:

Pretty sure he used the bing.com text I suggested.

Perfect. Everything is fine now, Thanks a lot.

WOOHOO! This thread helped me solve this issue!

these didn’t work for me:
bing/ncr
google/ncr
google

As a recap:
Navigate to: C:\Program Files\SketchUp\SketchUp 2018\Resources\en-US
Modify: i18n.dat
With this URL:
[ONLINE CHECK]
ONLINE_TEST_URL=https://www.bing.com/

For your interest, ncr was a Google specific thing, to prevent you from being redirected to a different country’s Google page. It was bound not to work for Bing, and I suspect that it fails these days for Google as well.

So far this change to ONLINE_TEST_URL=https://www.bing.com/ seems to have worked for all Mac users who had the problem. It may be that macOS was changed recently to prevent http requests from getting through.

Thanks, that did it. So it was a change that Google made…

Thanks, this got my internet connection to SU back (I used www.bing.com)
I can now connect to Generate Report, where I could not before change, but when it opens it shows:
ERROR: Uncaught ReferenceError: google not defined @/2018_generatereport.html?hl=en[14]
(after I click ok box) Template Manager then opens allowing me to “edit report” as normal.
When I try to “RUN” report this next error shows:
ERROR: Uncaught ReferenceError: google not defined @/compiled.js[155]
(after I click ok box) It freezes on “Generating Report…”
Please advise on what I might try to Generate Report at this stage
Thanks