Styles seemed to change suddenly ~ Design Style missing


#1

All of a sudden the Design Style is missing from styles. Also, when using hidden line style, the profile edge is gone. I check it in edges and update the scene but next time I go back to that scene, profile edge is off again?
Using latest Pro 2017


#2

I don’t know that I’ve ever seen a style with that name. What library would you normally expect to find it in?

Are you updating the style? If you don’t update the style, do you get the warning message that the style has been changed but not updated? If you aren’t updating the style before updating the scene and you’ve disabled the warning, the style won’t get updated with the scene update.


#3

Design style is light blue background. Easier on the eyes :wink:
I have not updated the style.I’ll try that


#4

Do you mean “Architectural Design Style”?


#5

I do not get that pop-up?


#6

Because you disabled it. By default, that warning is enabled out of the box. It has to get turned off by the user to quit showing up. Go into Preferences>General and turn it on again. And in the future, when creating or updating scenes, tick either the first or second box as appropriate.


#7

I update my scenes constantly and never had the need for that pop-up. IT always worked and scen would update without it. This just started happening yesterday. Never had issue before and this design style (not architectural design) has been a default style as long as I can remember?


#8

The warning will only pop up if the style has been modified but not updated before creating a new scene or updating an existing scene. It also requires that Style and Fog is selected as an attribute to save with the scene. This is not new to SketchUp but has been around since Styles became a setting option.

I went back to SU2016 and SU2015. That’s as far back as I can go on this computer. No sign of a style called Design Style. Evidently you have it in some version of SketchUp so you could copy it and add it to SU2017.


#9

Went from 8 Pro to 2017 Pro about 2 months ago and this just started today? Weird. Started with even earlier versions of SU so maybe it was in one of them and I’ve just brought it along with every new version. I’ll figure it out and thanks for the workarounds. I ain’t wantin’ no fog in my scenes, LOL!


#10

That warning window was in SketchUp 8 and earlier. As I said, it’s not new.

If you’ve brought your template along through various versions and it used the Design Style, you would have brought that style in your In Model styles as it shows in your screen shot. Or, if you’ve opened and old file create back in SU8 with that style, it would be present. You can save it into a library from the In Model styles just like you would any other style.

As for Fog, you only get that if you turn it on. It’s a style setting, too.


#11

It always was in my default styles but doesn’t show there now. Can it be saved there? Not seeing how to do that? For the window, I must have always had it turned off and never had a prob with scenes updating.


#12

Yes. First, you need to find the Styles folder in Program Data/SketchUp/SketchUp 2017/SketchUp and edit permissions in the Security settings to allow full control for your username.

Then in SketchUp, open the secondary pane in the Styles window, set one to Default Styles and the other to In Model. Drag the style from In Model to the other window.


#13

Thanks SOOOOO Much Dave. I appreciate your knowledge!! We can always learn and you taught me some great stuff today. Thanks man!!


#14

This topic was automatically closed after 91 days. New replies are no longer allowed.