Styles don't render a complete image


#1

I have read of many folks using styles for that “hand-drawn” feel, and it’s the main reason I got SU Pro. No matter what model I make or import, when I look at the various styles, they are never fully rendered. Choosing any of the “sketchy” styles leaves whole sections and/or components blank. The only styles that seem to work consistently are Hidden Line and XRay. I can think of a use for those two, but . . . .
Thanks.


#2

Sketchy Edges will not render if the (real) edges are hidden.
Thus it sounds like the “blank” components contain hidden edges.
There’s a handy plugin you might try which unhides globally, unlike SU’s native Unhide command.

Unhide All SketchUp Plugin by R. Wilson
Description:
Unhides ALL entities, including those in (nested) groups and components.
Allows for a single-step undo, just in case you decide to change your mind.
How to install: Just drop it in Plugins folder.
UI Location: Plugins

-Geo


#3

Cool idea. Don’t quite understand the “contain hidden edges” concept, but OK. When I went to download the plugin, into my plugins folder, I do not have a plug-ins folder in my Sketchup 2014 folder . . . . In the Tools folder, there is a RubyStdLib, and I see this plugin is from Ruby. Is that where it goes?


#4

By definition a Face can only exist within a closed loop of coplanar Edges.
Edges and Faces are unique entities which have properties; visibility is one of them.

If at first you don’t succeed, read the directions… http://help.sketchup.com/en/article/38583

-Geo


#5

All the Sketchy Edges styles have a function that adaptively hides or degrades edges and profiles. This can be somewhat controlled with the “Level of detail” slider in the Window menu>Styles>Edir>Edge settings dialog.

I personally prefer the vector-only styles.

Anssi