Lines disappear on edit, styles change


#1

AverageHouse.skp (1.0 MB)
I have a problem when editing the attached file. The SitePlan scene and the Plan scene have different styles. On the SitePlan scene, I double click the well to edit it. If I set View>Component Edit to Hide Rest of Model, the lines disappear while I’m editing. If I close the component and then switch to the Plan scene, the Style has changed.
Why did the lines disappear when I tried to edit the component (but only after I selected Hide Rest of Model)?
Why did the style of the other scenes change?
What could be going on?
Huck


#2

huckrorick,

an interesting find. The sketchy style you implemented uses a different technology to render to screen. I would think this has something to do with it. The workaround would be to just select a non sketchy style to allow yourself to work. The scene will still use the sketchy style you assigned it so you shouldnt have to modify the scene. Just use an alternate style when you are modeling.

@jody would you think this a bug?

CD


#3

Hi Huck & @ChrisDizon,

I tried to reproduce this in a new file.
I saved the Style (Pen Black1) which was saved with the Scene (SitePlan) to a local collection.
Then I copied the well component and pasted it into a new file.
There in the new file I browsed to the local collection and set the Style to the Pen Black1 style.

Then I edit the well component and toggle View > Component Edit to Hide Rest of Model.
The sketchy edges do not disappear.
It also makes no difference if I delete the Layer (OtherBldgs) that came along with the well component.
I tried the same routine in SU8 and SU2014. Both behave as expected.

My guess is the file AverageHouse.skp is corrupt.

-Geo


#4

(Although I’m not Jody) I do consider this a bug. It shows an unpredictable result that can’t be explained by the user. Also ‘Entity Info’ shows that you can still select the arcs that aren’t visible, this unlike when Edge Style > Edges is turned off. The user is left in the dark.


#5

With Geo’s experience in mind it seems that I have to come back on my words in previous post about the bug. Sorry for being too hasty.

Yesterday when I opened the file I noticed that I couldn’t select the upper (active) section plane in SketchUp 14. So I started again today. The plane was selectable this time. So I thought the file was ok anyway. But there seems to be this other thing (Geo’s catch) with that specific “Well” component.

The reason I tried the file again today is that I wanted to see if there was a mirrored component involved in the file with a section plane in it. For that would show a bug for sure. The wrong side of the section plane becomes selectable while the visible site is not.


#6

Nice testing! A good file for the team to look at.


#7

@Wo3Dan
I also noticed difficulty selecting the section planes.
And as you mentioned, the difficulty selecting the section plane was inconsistent.
Sometimes a plane could be selected, sometimes not.

@huckrorick
I noticed there are fourteen Styles in the file.
Purging the file reveals only six Styles are in use by the various Scenes.
The names of all six Styles indicate there was a fair amount of Style editing.

The Style that is saved with a Scene ultimately controls how the model is rendered in that Scene.
However, the way an active model is rendered onscreen is contingent upon two factors…
…the active Style and any temporary unsaved changes one may have made to that Style.

When a Scene is created the only Style properties that are saved are those of the active Style.
Any unsaved changes one has made to the active Style are not saved with the Scene.

Before creating a Scene, consult the Styles Browser.
If unsaved changes have been made to the active Style you’ll see update arrows superimposed upon the style thumbnail image.

When saving Layers, Section Planes and Styles in your Scenes it’s best to create Scenes using the Scene Manager (expanded) rather than View > Animation menu or Scene Tab > Context Menu.
Keep the Styles Browser and Layers Manager open so you’re aware and in control of what’s being saved with the Scene.

-Geo


#8

Thank you for all these comments.
So far I haven’t figured out how to fix this?
I’ll work on this a bit. Anyone please let me know if you see how to make this drawing behave more reasonably.
Some of your experiences are puzzling also, e.g. not being able to select a section plane.

There is something else that happens which I ran into in the past but forgot what the solution was. That is, at certain times the model acts like there is a section plane (or something similar) so that part of the model is not visible. As I rotate the model the not visible part changes as though some kind of section plane were obscuring it. ???


#9

To me, the file doesn’t appear to be fixable. Nonetheless, I wouldn’t be too concerned.
The issue is easy to work around by temporarily switching to another style when editing geometry.

Many of your scenes have the camera looking straight down in Parallel Projection mode.
Parallel Projection is very prone to clipping when you subsequently orbit the camera.
It’s handy to setup a shortcut to toggle between Perspective and Parallel Projection

Camera Clipping Plane — SketchUp Help

-Geo