Coordinating Sections, Styles and Scenes

Trying to learn how this is done.
I’ve built a house model and drawn section cuts thru it: Floor Plans, Long Sections, and Trans Sections.
The first scene (Model) is the whole model with section planes.
That scene is connected to a Style named “Model” that has sections planes on but section cuts off.
I am now trying to set the “FloorPlan2” scene with a different style.
That Syle is named “FloorPlans and Sections” - it has section planes off and section cuts on.
But when I click on the Styles icon for “Floor Plans and Sections” nothing happens.

Here is the screen shot. The highlighted Style is the Model Style. The non-highlighted Syle is the “FloorPlans and Sections” Style.

Screen Shot 2019-03-03 at 10.08.34 PM.png

Can you share the SKP file? Or upload it to Drop Box and share the link? It’ll be much easier to give you an exact answer with the file in front of me.

My guess is your styles don’t actually have the settings for the sections set correctly or you don’t have Styles as a property to save on creation or update of the scene.

Thanks, going to bed now though.
Will try again in morning.

No. Not necessarily. It depends on how you need to show things in the model. Section plane, section cut, and section fill states are style-related settings so if you have some scenes with sections shown and other scenes without sections shown, you’ll need different styles for each.

Assuming you have the same style settings for each scene, you can get away with a single style for them. You should go through the various tabs under the Styles Edit tab to see what the different settings are.

Well that’s what I thought.
I’ll look carefully through all the Style settings and see if there are conflicts.

It’s funny to me how the Styles arrange themselves in the opposite direction from Scenes.

I don’t understand what you mean by that. The styles are arranged in the Styles panel in alphabetical order.

Ha!
Okay then.
I’ll change the names.
… for some reason I assumed the Styles would arrange themselves beginning on the left and adding Styles moving to the right like the Scene tabs. But the opposite happened and I found myself having to think backwards when trying to associate Styles with Scenes.

Give your new styles logical names so that you can easily select the right one for the job.

Mmm, renamed my two Styles and they stayed in the same place.
Ill look for some additional tutorials, but if I still find myself stuck will send you the file.
Hate to ask that of your time tho.
Never used Drop Box but will try.

No worries. Send me the link to the file via a PM if you can’t make it public.

BTW, I believe I’ve experienced a bug where I can’t seem to choose a second style. You can click on the second style, but it won’t take. If there are only two styles, your stuck. If there are more than two styles, you can sometimes select a different one from what you want, and then you can switch to the one you’re trying to get to. It’s odd, and I don’t see it all the time but I’ve seen it more than once.

BTW, I think I’ve discovered that I have not been updating my scenes properly. This may be the problem.
I think I’ve made progress.
Been able to save 3 scenes with different Styles.
Still a lot of funny behavior I don’t understand - very tricky territory here - seems to me.

BTW, after renaming scenes, do this to resort them alphabetically:

53%20PM

Check something for me. Under the SketchUp menu, left of File, open Preferences>General. Is the tick box for Warn of style changes when creating scenes checked? If not, do so and leave it checked.

Yes, it was checked and I’ve left it that way.

1 Like

BTW
Section Planes are not adjustable correct?
They cannot be resized larger or smaller at will - correct?
Just one size that encompasses limits of the model …

Well, sort of. You can add a section plane inside a group or component to limit the geometry affected by the section cut but the section cut will encompass all of the entities within its context.

Helpfull
Thank you

1 Like