Style setting Issue

I recently updated from SU16 to 17. Everything was running fine until I need to export images. For whatever reason, they rendered with all of these crazy colors. The visual of the model on the screen is fine. It’s when I export. see attachment

It looks like it is taking every face, and splitting it into two triangles, one black, one in a random color.

Here’s what I’ve tried:

  • uninstalling and reinstalling as administrator

  • Repairing as administrator

  • Rebooting my computer

  • The file was initially created on SU16, so I thought that was the issue. However the issue happens when I open a new SU17 file from scratch

  • The color distortion or whatever you want to call it shows up in the styles tab. You click any default tab, and it just changes the random assortment of of colors. You make a style from scratch, same issues…

  • I’ve messed with anti-alias settings and I’ve got nothing

  • My multisample anti-aliasing is set at 0x, and can’t be changed to 4x

  • I’ve turned fast feedback on and off

  • In the Model info tab, I turned on and off anti-aliasing rendering, and I’ve got nothing. Turning it off just makes all the textures on the screen look pixalated.

    My next step is to up date my graphics driver if I can. I really have no clue what is going on.

Update. I ran a computer scan for updates to my drivers, and Windows said I currently have the best drivers for my computer… So now I really don’t know.

Could you export a picture and add it to your next reply? I wanted to see if there’s something about the way in which it is wrong that might give a clue about the problem.

Did you notice by the way that your Styles preview is messed up the same?

There is one of the exports in the center of the image from the original post, here is another:

With all things considered, it looks pretty cool, but the community in which I need to present this to on Monday wouldn’t be in to the whole disco ball theme.

I suspect they have no sense of humor!

Were all the faces the default material, or various materials?

A quick way to test and a workaround would be to Save as back to 2016 and open it there and see what you get.

Does the preview in the Styles palette also go through OpenGL?

Took it into the office, and saved the file as SU2016 (we haven’t updated the office to 17 yet), and everything worked absolutely fine. The styles were normal, and the export was fine. Something about 17 and my laptop.

You can run both versions on the same computer.
It is generally recommended that you don’t uninstall your current version when you update. This allows you to have an uninterrupted work flow.

1 Like

Try updating your graphics card driver.

Does this happen with all your files or only this one? The OpenGL artifacts in the export look much like the ones that appear when the model is very far from the model origin or if the model’s extents are very large. It might be that the trigger for these is affected by your driver so you get different results from different computers.

Do you have a list of installed plugins?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.