Help! Colors palette broken - showing loads of grey boxes, not resizing properly

Halp! My colour palette is broken. It’s showing loads of empty grey boxes. When I reduce the size of the box it they all remain and only the section that shows the actual colours in model compresses. It’s incredibly annoying.

Things I’ve tried:

  • searching these forums
  • updating to the latest SU
  • Resetting the workspace in Settings

I feel like there’s going to be an easy fix for this, like “go to X directory and delete Y file”. Are you the magical person who has that fix please please pretty please?! :pray:

— Edit to add:
I’ve used SketchUp for over a decade. I teach SketchUp. And I have a computer science degree. This isn’t some n00b screw up where I’ve accidentally resized the box and forgotten how to get it back again :laughing: It’s some kind of bug that I’m hoping some manual reset in the ~Library or similar directory is possible, otherwise I’m going to have to do a full reinstall.

The Colors pallette isn’t broken. Those little squares are supposed to be gray unless you drag colors into them. That’s a standard Mac thing.

@DaveR I’m not an idiot :joy:

There are usually two rows of them, max. Not several hundred as shown here. They take up most of the height of the screen and make it almost impossible to see the colours I’m actually using without making the palette massive.

Put the cursor on the line separating the palette from the tiles and drag it downward.

1 Like

@slbaumgartner There is no line. Literally the only re-sizing I can do is from the bottom right corner.

There is a little tiny dividing line that you can click on and drag to show fewer grey boxes.


I didn’t say you are an idiot. Don’t put words in my mouth.

@TheOnlyAaron beat me to it. I had an almost identical animation I was going to post. I misled you by saying you could just hover the cursor there (maybe that was true in earlier versions?), but as he shows you have to click first. Sorry about that.

Holy moly I would never have found that line! I had no idea it even existed. Thank you so much! Problem solved. PHEW! Thank you!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.