Style fill tool does not work now?

Hello all. I have encountered a new problem working in Layout. It seems my style color fill tool no longer works? When I try to eye drop and select a color, nothing happens and no color is recognized. I need to be able to fill shapes with certain colors that are in my layout document. I have had no issues up until now. I have tried closing the program. Restarting my computer, and updated with the new sketchup version 2020 but the issue remains…would love a solution on how to fix this.

Are these shapes drawn in LayOut? Do you have the Fill turned on and do you have the color swatch selected for the selected shape? Can you share your LO file so we can see what you’ve got?

Confidentiality purposes I cannot share my file. The problem seems so ridiculous and simple. The shape is just a circle I have drawn in Layout. These shapes already have a color in them, fill is on etc. I need to match a color from an image to put into a shape. What I usually am able to do is paste in my picture, use the style eye drop tool to grab the color I need, and then fill my shape with it. But it isn’t picking up any color, it just stays white.

It works for me in LO2020.

I mean it literally was working yesterday and now it is not. So I am at a loss.

Did you install SketchUp and LayOut correctly? That is, did you right click on the downloaded installer and choose Run as administrator? We’ve seen other weird behavior when they haven’t been installed correctly.

1 Like

I usually run it as administrator yes. I’ve had both installed for months and have not had this issue, so I guess I don’t know why all of a sudden it would not work? I tried updating my Sketchup today in hopes that would resolve it, and it did not.

Do you mean running SketchUp/LayOut or running the installer to install them on the computer. You need to run the download installer using Run as administrator but you shouldn’t use that to just open the program.

Does that mean you downloaded and installed LO2020.2? And did you right click on that downloaded installer and choose Run as administrator?

I run the download installer as administrator, not for the program.

Can you do this color thing in a different file?

I cannot do it in any of my files. Ironically, I uninstalled the newest version, reinstalled the 2019 version, and it works fine. I tried uninstalling and reinstalling 2020 and it still didn’t work. Looks like I have some work to do saving my files in the 2019 version and just sticking with that one for now…

It’s working for me in 2020.2. I showed that in my GIF. It’s not a feature that was disabled.

What graphics card is SketchUp using?

Just for grins, make a file you can share that shows this problem and upload it here so I can try it on my end.

My graphics card is Intel ® UHD Graphics 630. I’ll make a blank file.

2020 TEST.layout (20.3 KB)

Your profile also indicates Nvidia.

There was a Windows update last night. Perhaps your computer got it, too. It’s common for Windows updates to include broken graphics drivers for the integrated Intel GPUs. Go to the Intel site to download and install their latest driver version. Then restart your computer.

From your LO file in LO2020.2

I’d have to say it’s not LayOut 2020.

It just has it out for me apparently! I literally cannot do that when I am in it.

It was working for you and quit overnight. What changed on your system? That’s where the problem is. As I said, there was a Windows update last night.

So I updated my driver as you suggested and the problem is fixed! Whew! Thank you for your help, much appreciated.

1 Like