Fill does not work

The background color on my viewports (?), if that’s the name of the box where I’ve pasted one of my views, won’t change. I can get a color into the fill box in the colors pane, but I can’t get that color into the viewport.

We can only guess with so little info to go on.
Add your layout file and an image showing your issue.

1 Like






Box
July 11

We can only guess with so little info to go on.
Add your layout file and an image showing your issue.







Box
July 11

We can only guess with so little info to go on.
Add your layout file and an image showing your issue.

A screen shot doesn’t cut it. Attach the LayOut file that includes the viewport.







DaveR SketchUp Sage
July 11

A screen shot doesn’t cut it. Attach the LayOut file.

steel support.layout (15.8 KB)

That is not a viewport (which would come from a SketchUp model) and it isn’t geometry drawn in LayOut. It’s a PNG image file. You can see that in the References list.


PNG images cannot be modified with the Shape Style settings in LayOut. You could edit it in an image editor. My editor is PaintDotNet.

After editing the background color from gray to magenta in PaintDotNet and saving the change.

How did you get this image in the first place? Did it start with an imported SketchUp file? If so, it would appear you exploded the Raster rendered viewport which would leave you with an image.

Ok, thanks.

You’re welcome.

Did that really come from a SketchUp file? If so, you could skip the Explode step in LayOut and then just change the background color to what you want by editing the style in the SketchUp model. Or, if you are really set on exploding it, render the viewport as Vector first. Then explode it. The background will become a LayOut drawing object as will the thing you drew. You can then edit the fill color. I did that here.

Thanks again, Dave

Yes that file came from sketchup. But I may have inadvertently changed it to a png or jpg. I’ve been confused with fills. So, I do a lot of flailing about. I hit buttons, change things, etc. all to get the results I’m looking for. Along the way, I lose track of where I am and where to go. It was like that with SU for a while, and I’m sure, with some more time, I’ll get the LO working.

Richard

OK. If you want to leave it connected to the SketchUp model don’t explode the viewport. Remember, though, that most of the settings in Shape Style have no effect on Sketchup viewports. Stroke will allow you to display borders around viewports but that’s basically it. The appearance of the model is controlled in Sketchup and in the SketchUp Model panel in LO.

Maybe spend some time with the LayOut Essentials.