Students can't access sketchup for schools

Good morning,
My school district subscribes to the google suite, our administrator has launched sketchup for schools, as a teacher, I can access and use sketchup, my students can not. They click to open sketchup and it is stuck on the page with the sketchup logo. Any suggestions on how to remedy this?

The majority of the students are trying to access sketchup with chromebooks. I don’t know if that would make a difference in access or functionality.

What url did you use? https://edu.sketchup.com/app Just tried in an anonymous browser with a non-work email and it worked. Chomebooks should work fine.

That is what I’m having them use. They are getting stuck on a white screen with the sketchup logo. One student got in briefly and when he tried getting back in, he got stuck on that same screen.

Sounds like some kind of crash. Can you open the console and see if any errors are showing up? And If so, could you send screenshot to sam@sketchup.com? It may be a bug we need to fix. You can probably get to the console by opening [three vertical dots] > More Tools > Developer Tools but I’m not totally sure if that is the case on Chrome OS.

Is there a chance the log on screen pop up is behind the currently open browser?

1 Like

Hey all, I’m the tech admin helping Ray.

I’ve troubleshooted this both under a teacher account and a student account using a Chromebook. I don’t have any issues with the Chrome browser when on a desktop.

All of our students use Chromebooks. I’ve deployed it from the admin console in Google and we do indeed see the Google login screen. It allows us to proceed with the login. But then it often hangs on the white screen with the logo. I’ve let it sit and had it eventually go through after 15 minutes, but most often it never goes through. The last two times I tried a few minutes ago here and it let me right in. So it’s very inconsistent as to why it’s hanging, which makes it difficult to troubleshoot. I’ve also tried clearing the cache and all app data, restarting the chromebook, but still no luck.

Under developer tools, it did kick up a ton of errors, which you can find here: https://docs.google.com/document/d/1DMH54YnYj5IvB6N65QKXo_dFxjauVISfCy0PNswUwgQ/edit?usp=sharing

Thanks for being patient. None of us can see any errors that should stop you getting into the app although it could be getting logged elsewhere. Are you sure that the login popup is not getting blocked? Re-opening the login page after the browser has shot it down doesn’t work reliably so it is better to avoid it getting blocked at all in the first place.

I was definitely able to click “Login with Google” and then click my school user name with no issues.

I sent you a direct message with another thing we can try.

To anyone stumbling across this forum thread in the future, the problem was one of our Google integrations loading a file called “proxy.html” which the school’s filters blocked. That caused the whole app to get stuck loading. In the future we may try to do a better job detecting this sort of error automatically so that we can show a warning. But for now, whitelisting that particular file seems to have fixed the issue.

Can you provide details on white listing the file.

I am having problems with a few students accessing the sketchup for schools app on their Chromebooks. They all have a g-suite account and are able to log into google, but some are having difficulty logging in while most seem to have no issue . When they cant login the error message attached is what they get.

Are your students using their G Suite education accounts, or personal gmail addresses?

I am currently using Google Sketchup for schools for distance learning. I have approximately 100 students using it successfully. 2 students have had experienced the same white screen with Red logo. 1 of them received the same error as menioned above while another got this error message. “Sorry. We encountered a problem with your web browsers WebGL support.” This error occurred while on the white screen with Red Logo. Any suggestions?