Strange results trying to make sphere

Hello folks,

I’m new to sketchup and still finding myself wondering why the video tutorials never seem to work for me when they plainly work on YouTube. Generally it’s me but I’m really stuck on making a sphere. I’ve followed a few tutorials like this one. but I keep getting differing results and I can’t see why.

Mostly I am getting a sphere with the north and south poles clipped off like this.

sphere.skp (260.8 KB)

I’m using SU Pro on a MAC if that’s relevant and the layout in mm template.

What I want to do is create a sphere that I can 3D print that’s 60mm in circumference and has 2 x 3 mm holes in its face at 12mm centres.

So starting with a sphere seems like a good place to start but I’m open to advice on the best workflow.

Thanks in advance


Part of your problem is likely to be that you are working too small. Because SU was originally developed for architects, it can’t create very small edges (< about 1/1000th inch) but it can preserve them if scaled down.

So model in metres as if they were mm - 1000x bigger.

Then scale down when done.

But that isn’t the cause of such big gaps in your sphere. Not at computer at the moment, but will try a demo for you later today, if you don’t get a solution from someone else first.

Did you actually mean 60mm in circumference? Or diameter?

Hi John,

Thanks for the quick response. Much appreciated.

I’ll try scaling it up.

Yes, eventually I would like to try and print a sphere in two halves at as near as possible 60 mm circumference. Which is around a radius of 9.554140127388535 mm

I’m thinking 60 mm just to keep the math simple for spacing the holes. The holes will have some 2 x 2 magnets glued in them. So scaling down will make it tricky to get the holes the right size and the circumference right.

I might get past that by creating a surface mesh and then physically drilling the holes out later.



What kind of a 3D printer do you have? I find on mine that to get a hole the size I want, I need to draw it bigger, by roughly twice the nozzle diameter (0.5mm in my case). So to get a 2mm D hole for your magnets, draw the hole 1.25mm R (2.5mm D).

And to adjust the fit from tight push fit to easy slide in fit, try increments of about 0.05mm R. (Or 0.05m in your scaled up drawing.)

At least that is true for holes in the x-y (red green) plane.

More complex when more nearly in a vertical plane - the height of the hole comes out about right, but the width a bit smaller than drawn.

Often, it’s easiest to get the hole to print a bit small, then drill it out.

Hi John,

You were right about the scaling, thanks.

Thinking about this more deeply, the sphere I now have has no thickness to its walls and presumably has two circles within it of no thickness as well. This will be my first attempt at 3D printing so I’m reading up on that in parallel. What I’ve read so far suggests that walls of zero thickness are a bad thing for 3D printing, which seems intuitive. So I need to work out how to give the sphere a thickness. The push pull tool doesn’t seem to like spheres.

I don’t currently have a printer but will be trying it out on my brother’s ridiculously expensive one later on. Not sure what make it is right now.

What I might try and do regarding the sizing of the holes for the magnets is just put in tiny pilot holes and then physically drilling them out to size. Rather than repeatedly printing until I get it right. The design doesn’t really require high tolerances. I just need to get the magnets in there and glue them in.

Thanks for the help


For 3D printing, use a ring instead of a circle for the profile. That will give the wall thickness you need. SketchUp’s surfaces are only that. Make sure face orientation is correct with the white front face to air.

Shown with a section cut after Follow Me.

1 Like

Ah! nice.

Many thanks

FWIW, if the slicer software you’ll be using has an option for setting import units, you might find it easier to set SketchUp units to meters. for a 60mm dia. sphere you would model it as 60 meters. This gets you around the tiny face issue. Since the slicer programs I use do allow for setting import units I don’t bother scaling the model down in SU before exporting the .stl file. .stl files are unitless anyway. I export the meter-sized model as .stl and then import it into the slicer as millimeters.

FWIW the problem with spheres is that the the way follow-me builds them is like an Earth with latitude and longitude lines. The longitude lines converge at the poles, making smaller and smaller quads and finally triangles. Unless the size is large enough compared to the number of circle segments you chose, those quads and triangles become too small for SketchUp to create.

You do know that you can scale down to exact dimensions, starting from any large ( or small) size model/object. As long as you include the units with your input. Or by using the ‘Tape Measure’ tool.

Ah that sounds simpler, cheers :slight_smile:

Yes I can see that when I show the hidden geometry, thanks

Thanks, I think I’ll keep it large and go with the idea of setting the units on import into the slicer.

Cheers Guys

Here’s an example from a model I did yesterday. I don’t think I’ll actually be printing this thing, though.