SketchUp incompatible with Polar?


#1

Just got anew Polar printer, but anytime I try to print something I built in SkUP it comes from SkUp to the printer too small. Like microscopic. No amount of scaling up seems to help.

Anyone experienced this or have ideas?


#2

I’m guessing it doesn’t go directly from SU to the Printer. Do you have to export it as a specific file type then use printer software to send it to the printer? If so you may be exporting incorrectly. Check for example that you are exporting at the correct scale.
It would help if you gave some information about how it gets from SU to the printer.


#3

Im exporting as an STL then uploading to the Polar Cloud. When I exported the same file and then ran it through Cubify it worked fine.


#4

Sorry to clarify worked fine on my old Cube


#5

Can you post a simple model and the .stl that you export from it so I can look at it.


#6

Here it is.name with box (1).stl (346.2 KB) Thanks so much for your help


#7

I suspect you are exporting with the wrong scale measurements. What exact size should the box be? Just give me one specific measurement Like full width of lid.


#8

This one is 2 in x 2 n x 2 in Bpx.stl (53 Bytes)


#9

Try this one.
Resized Box.stl (378.7 KB)


#10

It worked!!! Now can you tell me how you did it?


#11

I suspect, if you are using the same .stl export plugin, that there is a fault with exporting in inches.
Scale your model to exactly what you want in inches, but when you export to .stl choose millimeters in the .stl Export Options dialog. Seems to work for me.


#12

Thanks very much I will try that


#13

FYI, STL file format does not have a “official” means of specifying the units used.

Some companies (and printers) expect the number to be in mm, others in inches.


#14

True @DanRathbun but in this case, the .stl exporter from the extension warehouse authored by The Sketchup Team, appears to have a bug in it where exporting in inches produces a tiny result. The tiny result is the same no matter what stl viewer or printer software you open it in. Therefore it seems not relevant to the different printer software, rather to the export plugin.


#16

I’m not sure what you are talking about there.
I was referring to this plugin.
https://extensions.sketchup.com/en/content/sketchup-stl

But it doesn’t affect me as I don’t use inches.

Edit:
Ok Dan, I understand we were looking at different things.
I’ll leave this here for the extension link anyway.


#17

It is not a bug in the stl exporter, it is a “bug” in the STL file specification. STL files do not have units. So if you export a model using inches and your 3d printing software assumes mm then the import is naturally going to be much smaller than expected.

maybe mm should be the default export unit for the sketchup exporter. Probably the documentation could be changed to make this more clear and obvious.