Drawing spheres

Hi all. Drawing spheres is such a simple task but I’m getting the same problem every time. My spheres always have a hole in them both top and bottom. Does anyone have a fix for this or been experiencing the same issue?


Have a look here.

I’ll give that a try. It makes sense. My model is only 58mm in diameter and the sphere uses 100 segments. I need the smoothest sphere I can get so I can 3D print it. I’ll give the scale-up thing a go, thanks.

That worked. I scaled my model by 10 and I get a perfect sphere now. Thank you.

1 Like

For 3D printing purposes I always model with units set to meters to avoid the tiny face issue. No need to do any dimension conversions. I also don’t scale down. I export the .stl file with units set to Meters. Import units are set to millimeters or inches as appropriate.

Your sphere modeled at 58 meters in diameter. I was a little excessive with 180 for the number of sides on the circles.

And after import at millimeters, it’ll be 58 mm in dia.

Sphere.stl (1.5 MB)

Another example that is dimensioned as inches but modeled with units set to meters.

Uploaded to the slicer:

As an addendum to Dave’s excellent suggestion,
Some printer software doesn’t allow you to change the import units, but Sketchup does allow you to change the export units. (options setting on the export dialog) So a simple way to work out what your export settings should be is to create a 1m cube and export it 3 times changing the export unit settings each time (m, cm ,mm) and see which imports into your printer software at the size you want.

1 Like