Stop objects snapping to section planes

Using SketchUp Free (I assume behaviour is the same in the desktop versions), I’ve found that when I draw/resize a rectangle which happens to be perpendicular to my section plane, the nearest edge of this rectangle snaps VERY aggressively to the section plane. The only way to avoid this is to place my viewpoint on the same side of the section plane as the rectangle and to zoom in so that no part of the section plane is visible on the screen.

Can anybody explain why SketchUp behaves like this, and if/how this behaviour can be turned off? Section planes are a visualization tool, NOT an integral part of the model geometry, so it’s bizarre (and incredibly frustrating) that geometry elements would snap to section planes!

You can hide the section plane if you don’t want to snap to it.

Thanks; just to be sure, hiding the section plane will not deactivate it (i.e. I will still have the same view of the model cut by the section plane)? Sorry, I’m on my work computer so can’t easily test it myself at the moment.

Section planes and section cuts are separate display settings.

With SketchUp Free, it doesn’t matter where you are, you can go to my.sketchup.com , log in, and continue. The View/Camera settings are on the right hand side.

There are three different options to achieve the same visible effect (leaving the section cut visible):

  • disable View > Section Planes (see Display menu on the right in the web version)
  • right click on a section plane > Hide ( in the context menu that appears)
  • create an extra tag that you then assign to the section plane > turn this tag off in the list of tags.

Each of these options have their own (dis-)advantages.

They all allow you to create rectangles without the section plane(s) interfering your drawing actions.

1 Like