Section plane showing up when toggled off SU2018

sections

#1

Having an issue with section planes in 2018. I have a section cut going through two groups. When I try to double click on one group it won’t let me edit it. Instead it selects a section plane (with a dotted perimiter) that is currently toggled OFF. I have to rotate under the section plane to get to the group to open it.

When I double click on the other object, no section plane shows up and the group/object can be edited as normal. (I can select any line or face within the object and it doesn’t toggle the section plane on.

This happening in the same scene. Unless I’m really confused, I should never see a section plane when I have them toggled off no? Thats what you see here:


#2

Hello Brett,

A screenshot gives us little to work with.
Sharing a model that exhibits the problem will help us help you.


#3

SECTION ISSUE MODEL 2018.skp (184.4 KB)


#4

Are you trying to select the group while in Top (Plan) View? With camera set to parallel it would be hard to select the group instead of the section plane. The fact that it is dotted, is because you selected it, but the view is set to Hide section planes. If you want to select the group, try orbiting and select visible geometry of the group, otherwise you’ll still wind up selecting the section plane…


#5

But i’ve never had to orbit around to select before. That is very inconvenient and doesn’t explain why I CAN select the second object without orbiting but NOT the first and third (left to right). They are all being cut by a section plane that is toggled OFF. That plane should be invisible and out of the way.


#6

invisible yes, out of the way, no, it is controlled by View>Section Cut The second displays the bottom of the cube, so it is easy to select, the first and the third have relative small width walls, zoom in and click between the section line cuts:


#7

Mike, why can I edit the second object, but not the 1st and 3rd when clicking on them? Again, this was never an issue until 2018. I could always come from a top view and open objects that were cut by a plane. I want the plane to un-selectable, but every style and toggle option available is not letting me do this. The option to lock the plane is greyed out.


#8

Ok. So I have to zoom into to a face to be able to edit the object. That is not ideal either and different behavior than 2017. How do I prevent the plane from being selected instead of the object? Surely there is an option for this…?


#9

toggle View>Section Cut : Off> select object


#10

I want to be able to open the object with the section cut active. I see certain things when the section cut is on that I want to go in and edit without orbiting all the way around. I was able to do this in 2017.

p.s - I need to learn how to make the little screen recordings. Do you have instructions?


#11

2017 didn’t require me to zoom all the way into clicking on a face to edit. 2018 does.


#12

I think you’re right about that it was different for version 2017, it might be that with the new ‘solid section’ there is a change in the selection. Could be a simple stacking order @trent ?

I use LiceCap


#13

For now: make a shortcut for View>Section Cut
You can then toggle quickly.


#14

That will allow me to get into edit, but does require another step that I’m not used to and will slow me down a touch. Definitely different than the preferred method 2017. I dream in SketchUp I use it so much!

On a side note, I have yet to find a way to lock a section plane. There is an option in entity info, but its always greyed out. Thanks for licecap lead.


#15

You cannot lock section planes. You can Lock a Geometry Group/Component which contains a section plane, but you cannot group a section cut itself


#16

Things do appear to behave differently in 2018, where a selection click on the Section Line selects the Section Plane.
Given the improvements to Sections, I certainly wouldn’t call it a bug. Just a nuance we’ll all get used to.


#17

Interesting. Thanks. I’ve made video tutorials with MacOS’s built in QuickTime Player, but this forum doesn’t seem to like the file size of even a short clip made that way.


#18

This was a side effect of the rework of section planes and in particular Filled Section Planes… It is actually a result of having Fills on so you could as Mike had suggested create a shortcut to toggle off/on fills. Once this is off it behaves like it did in 2017. We have also created an Icon for Section Fills that you could toggle.

Trent


#19

Toggling section fills doesn’t really help. Even with them off, I now have to zoom way into objects and select a face in order to open/edit. That really isn’t ideal when working on large floor plans where 4"-6" wall faces become razor thin when looking at a whole floor plan. Only option now is to toggle section cut off, select/open/edit, toggle section cut back on. Again, not ideal.


#20

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.