STL plugin not compatible with Make 2017?


#1

Hi to the forum. I have Make 2017 64 bit installed on a laptop for the purpose of developing files for my new 3D printer. I tried to download the STL plugin but it popped up an error box saying that the plugin is not compatible with my version of Sketchup. Is this because of the 64 bit upgrade? The error box warns that the plugin will not be stable. Should I ignore this and download the STL plugin anyway? The whole point of this is to create files for my 3D printer. It will be useless if I can’t export .stl files.

Don


#2

without mentioning where you try to download from evaluating the problem gets difficult.

Download from the official source either directly from inside SketchUp by “Window > Extension Warehouse > SketchUp STL” or as a RBZ file from the Extension Warehouse website.


#3

I am downloading from within Sketchup. The message appears when I hit the red download button in the STL page in the plugins window. I also tried a download external to Sketchup but received the same error message.


#4

It should not say that if you are accessing from inside SketchUp. The red button should be labeled “Install”.

Check to be sure you are logged in via the little man icon in the lower left of the SketchUp window.


#5

I am fully logged in to Sketchup and yes the red button does say “Install” in the Extensions Warehouse page for the STL Extension. The Compatibility list on the STL page does list Sketchup 2017 as compatible. I suspect that the 64 bit upgrade has not been added to the STL Extension yet. The error message that pops up when I hit the install button follows:

“This extension has not been marked as being compatible with your version of Sketchup. You may experience usability issues if you try to install this extension”

Should I try it anyway?

Don


#6

Strange. it works for me with SU2017.

That message has nothing to with “bitness”.


#7

Back-track…

When you installed SketchUp did you do it in the following way ?
Find the SketchUp installer exe file [probably in your Downloads folder ?]
Select its icon, right-click > context-menu > “Run as administrator…”

If you did not do this, then all kinds of weirdness can ensue…

You might not need to uninstall and reinstall.
Close SketchUp.
Then try to run the installer as outlined above…
When prompted choose to ‘Repair’.

Any improvement ?

Reinstall the STL tool if it’s no better …


#8

Decided to download the extensions I need. STL gave me the warning. Solid Inspector2 and Clean up3 gave no problems and installed just fine. Nothing amiss so far. We shall see.