Spontaneous Crashes While Idle - basic_string::_S_construct NULL not valid

For the past couple of days, SketchUp Pro 2016 (16.1.2418) has been crashing after it has been idle for a few minutes (on an iMac with Mac OS Mojave 10.14.4). Has anyone seen this, and if so did you find a cause? The crashes are always similar to the following partial report from Mac OS (there is no SketchUp bugsplat):

Process:               SketchUp [572]
Path:                  /Applications/SketchUp 2016/SketchUp.app/Contents/MacOS/SketchUp
Identifier:            com.sketchup.SketchUp.2016
Version:               16.1 (16.1.2418)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           SketchUp [572]
User ID:               503

Date/Time:             2019-06-01 13:12:32.123 -0400
OS Version:            Mac OS X 10.14.4 (18E226)
Report Version:        12
Anonymous UUID:        <redacted>


Time Awake Since Boot: 240 seconds

System Integrity Protection: enabled

Crashed Thread:        1  Dispatch queue: com.apple.root.default-qos

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
abort() called
terminating with uncaught exception of type std::logic_error: basic_string::_S_construct NULL not valid

Thread 0:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff737f222a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff737f276c mach_msg + 60
2   com.apple.CoreFoundation      	0x00007fff4724a13e __CFRunLoopServiceMachPort + 328
3   com.apple.CoreFoundation      	0x00007fff472496ac __CFRunLoopRun + 1612
4   com.apple.CoreFoundation      	0x00007fff47248e0e CFRunLoopRunSpecific + 455
5   com.apple.HIToolbox           	0x00007fff465359db RunCurrentEventLoopInMode + 292
6   com.apple.HIToolbox           	0x00007fff46535715 ReceiveNextEventCommon + 603
7   com.apple.HIToolbox           	0x00007fff465354a6 _BlockUntilNextEventMatchingListInModeWithFilter + 64
8   com.apple.AppKit              	0x00007fff448cfffb _DPSNextEvent + 965
9   com.apple.AppKit              	0x00007fff448ced93 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1361
10  com.apple.AppKit              	0x00007fff448c8eb0 -[NSApplication run] + 699
11  com.apple.AppKit              	0x00007fff448b83f0 NSApplicationMain + 777
12  libdyld.dylib                 	0x00007fff736bd3d5 start + 1

Thread 1 Crashed:: Dispatch queue: com.apple.root.default-qos
0   libsystem_kernel.dylib        	0x00007fff737f82c6 __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff738adbf1 pthread_kill + 284
2   libsystem_c.dylib             	0x00007fff737626a6 abort + 127
3   libc++abi.dylib               	0x00007fff7071b641 abort_message + 231
4   libc++abi.dylib               	0x00007fff7071b7c7 default_terminate_handler() + 243
5   libobjc.A.dylib               	0x00007fff71e91eeb _objc_terminate() + 105
6   libc++abi.dylib               	0x00007fff7072719e std::__terminate(void (*)()) + 8
7   libc++abi.dylib               	0x00007fff70727213 std::terminate() + 51
8   libdispatch.dylib             	0x00007fff73670651 _dispatch_client_callout + 28
9   libdispatch.dylib             	0x00007fff73672de6 _dispatch_continuation_pop + 414
10  libdispatch.dylib             	0x00007fff73681f42 _dispatch_source_invoke + 2056
11  libdispatch.dylib             	0x00007fff7367e3bc _dispatch_root_queue_drain + 324
12  libdispatch.dylib             	0x00007fff7367eb46 _dispatch_worker_thread2 + 90
13  libsystem_pthread.dylib       	0x00007fff738aa6b3 _pthread_wqthread + 583
14  libsystem_pthread.dylib       	0x00007fff738aa3fd start_wqthread + 13

The reported event is always basic_string::_S_construct NULL not valid, though the specific thread that is shown as crashed varies. I have not installed or updated any new software or SketchUp extensions recently. All I can correlate with the onset of these crash-when-idle events is a power-failure that our neighborhood experienced two days ago. I have run the Mac OS Disk Utility on the volume, which reported no errors.

These crashes-while-idle occur with a model file open that I’ve been working on, or with the default nearly-blank-model open. The crash happens sometimes within a few seconds of SketchUp being idle, or sometimes after a few minutes (when I am working in another application, such as the Safari browser). I have rebooted the Mac, and the problem persists.

I have licensed copies of 2017 and 2018 Pro also installed, though I rarely use them (because I dislike their treatment of high-DPI displays). I just tried 2017, and it crashed with a bugsplat (which I submitted to Trimble) after 10 minutes or so of sitting idle in the default new model. I also launched 2018, and it’s been sitting idle for a few minutes, no crash yet. I have a license for 2019 Pro but I haven’t installed it (the new features don’t particularly interest me, and I don’t want to devote the storage space to it).

Only as an FYI, 2016 was released before Mojave so obviously isn’t supported. I run 2016 daily on Mojave, but n9t for hours a yr a time,. Are you able to upgrade?

Hi @Barry thanks for the reply. I upgraded to Mojave about six weeks ago. I’ve used SketchUp Pro 2016 for many many hours since that time, both actively sitting in front of it doing modeling operations, and letting it sit idle overnight. I almost never quit out of SketchUp, I normally have a session last for a month or more. This string-NULL-not-valid issue only started mysteriously a couple of days ago.

I understand that 2016 + Mojave is not a supported configuration (sob!). I would rather not use any later versions because I really dislike their support for high-DPI displays (at least on the Mac). The model’s edges and guides drawn in the viewport are thin single-pixel width in 2016, which allows me to see wonderful detail (screw threads, fillets, etc.) even with hidden geometry enabled. 2017 and later draw edges and guides with relatively thick lines (on all recent releases of Mac OS, not just Mojave), which obscures details until zooming in further than I would prefer. See the following post for a recent discussion of that topic:

1 Like