Spin wheel

I have been using SketchUp pro for more than a week. Now i see the spinning wheel is taking my toll out of my work! Keeps coming over and over again! How do i overcome this issue. I have switched off all the layers as well.

Try purging unused. Model Info>Statistics.

What kinds of actions are you doing in SketchUp at the point in time when the spinning-cursor appears? How complex is your model in terms of edge and face count (see Window->Model Info, Statistics)? Do you have Profiles enabled in the active style (they slow down orbiting and panning)?

Have you imported large png’s ?