SpaceNavigator Mouse doen't work in New Install of Sketchup 2018 on brand New computer


#1

I had Sketchup 2018 running on my laptop then I bought a brand new desktop and installed both my SpaceNavigator Mouse for Notebooks and Sketchup 2018 on it and the 3D Mouse doesn;t affect the Sketchup install at all. It doesn’t do anything. How do I get it to work with Sketchup 2018 on my new install? IO am running WEindows 10 Home Version on a 64 bit OS.


#2

Did you install the newest 3D Connexion drivers AFTER installing SketchUp?


#3

@TheOnlyAaron is right: the 3D connection installer puts its plugin into each installed version of SketchUp it finds. So you have to install SketchUp first.


#4

I installed Sketchup then I installed the latest version of the 3DWare software 3DxWare64_v10-5-7_r2779.exe


#5

Can you see the 3DxSketchUp extension in the Extension Manager?

Also, have you reached out to 3DConnexion to see if they know what might be happening?


#6

Yes the Extension is installed and enabled and fully updated.


#7

Does the mouse work with the 3d connection software application?

Have you tried it with the “training” part of that?

Is the mouse lit up and definitely plugged in/switched on?


#8

This is why I like Apple a lot. With my Macbook I didn’t had to install a driver for my 3d mouse. I connected it and it worked instantly. I also have a Win10-PC. Basically for Gaming and Lumion. But I also installed SketchUp on my Win-PC to see how it´s working. Then I also connected the 3d mouse and had to install the Driver. It worked fine first. But a few weeks later I started SketchUp again with the 3d mouse on the Win-PC, and the mouse didn’t work anymore. Why? I Don’t know! Scrap!
Sorry - I know this doesn’t help you. But I cannot understand, why a big and mighty company like Microsoft can’t afford one guy who´s looking after these kind of issues. :rage:


#9

You obviously haven’t suffered the memory drain issue caused by the 3d mouse that basically renders it Scrap for many Mac users.
An issue the mighty macs haven’t addressed.

@zipster1967 I would repeat what @DaveR asked you in another thread.

when you installed SketchUp, did you right click on the installer file and choose Run as administrator?


#10

Hold on. Memory drain issue? I was thinking of investing in a 3D mouse for use on my Mac. Are you saying it may not work well?


#11

There is a well-known and long-standing problem with initialization of the plug-in that can cause SketchUp memory usage to run out of control until your Mac crashes. A (admittedly awkward) workaround that works for me is to immediately close the default blank model window the instant SketchUp starts. If you are quick enough the memory leak won’t happen.

Despite multiple complaints from many people dating back at least several years, 3dconnection lacks either the interest or perhaps the competence to do anything about this bug.


#12

Well thank goodness I engaged with this thread. I don’t think I want to spend £££ on something to find I have to use a tricky workaround to stop it crashing my computer! That would be like buying a BMW and having to lug a big fire extinguisher around…no, hold on…


#13

More like a Ferrari - some of them are known to catch fire :thinking:


#14

#15

Or even:


#16

Can’t say I’ve noticed this issue. I got a space navigator about a month ago. What a wonderful bit of kit! It works like butter with SketchUp, no more sawing around with the mouse. I haven’t noticed a memory drain and i keep a pretty weather eye on the memory status as I use vray a lot and the texture burden is high.


#17

Yeah, the delightful way it replaces zoom, orbit, and pan even during another tool is why I put up with the hassle. It’s odd. Some Macs don’t suffer this issue and for others like mine it is every time.


#18

@slbaumgartner & @bifterx Could it be related to a particular Mac model? Which do you have? If mine is more like Rob’s than Steve’s, maybe I needn’t worry?


#19

I may have inadvertently created this hijack, but don’t you think, since the OP isn’t using a Mac, that this would all be more relevant in it’s own thread.


#20

@Box is right, but since we’ve come this far we may as well wrap it up quickly here. Mine is a mid-2012 MBP Retina.