Some Floor Plan Walls are Hollow after Section

I modeled my floor plan with extruded walls but after cutting a section some are hollow and some show “solid”. Why is this?

Post your model if you can. In these cases there usually is something that interrupts the clean loop of section cut edges. A very small gap, a hole-cutting component etc.

1 Like

This sounds like a typical misunderstanding of how Sketchup works and how language gets distorted.

Sketchup is a surface modeller so ALL 3D objects are hollow. They can be made to look solid by various means but they really aren’t.

The problem is compounded by the use of the word “solid” within Sketchup. To you and me a gaming die is a solid. But if you modelled one in Sketchup it would actually be a box.

If you cut a section through your die, you would see the back face of the opposite side, which might make it look solid. If that opposite side were deleted, it would look hollow.

The OP is talking about the Section Fill feature (a style setting). It can be tricky.

I did wonder but it’s not obvious from the post.

Thank you Anssi. This is the tip I needed. Rather than searching for the interruption I just erased and redrew the wall and it is good now.

Thanks for your reply! V helpful.