Some 3d baazar imported materials missing after purge

I’m having some trouble with my current sketchup model, using Skatter to lay out a bunch of ferns. Everything was fine until a little later I noticed some of the ferns had no materials, and I had done a purge a few minutes earlier.

What’s really strange is I can’t seem to get them back. I’ve deleted all the fern models, and reimported via 3D Bazaar. Still no materials, ferns render as black. These are multi-materials that were rendering fine previously and also render fine if I create a new sketchup file and import there.

I’ve tried deleting the locked objects that Skatter generates to ensure there are no instances sticking around.

What else can I try here to restore the materials?

Rendered in my main sketchup project:

Rendered in a new project:

ok I fixed it. What I did was go into the material list and deleted all of the fern materials manually. It warned me that there were objects using it - which is weird - as I deleted all instances of ferns and confirmed it via the Outliner (is there another way?)

I’m not sure if this is a known bug or not, but likely easy to reproduce.

Skatter puts a hidden/locked copy of any component you Skatter in the model to ensure one is always there if you want to edit. I think v3 even gives them their own tag.
If you go to 0,0 (where the axis show) and unhide all/show hidden geometry you should be able to find them. Alternatively you could look through outliner or the components list and delete them from there.

Deleting components from the model space doesn’t remove them from the file. They would still be in the In Model components and as long as they are the materials they use will be in model, too.

You should purge unused components first. Then purge unused materials. Or, in Model Info>Statistics click on Purge Unused. It’ll get rid of the components and then the materials.

That’s not a bug.

@DaveR Maybe I wasn’t specific enough in the original post, but Purge Unused is what caused the issue I encountered (or seems to have). The materials were no longer rendering from the components used to scatter despite them being in the scene (locked hidden objects were still there), and the only way to fix it was in my marked solution.

I just encountered it again but with different components. I don’t know if this is a bug with Skatter 2.0, SketchUp, or some other cause in my workflow. I’m not doing anything unusual, just using skatter against some landscaping components using Vray. The materials are listed, they are applied to the components however render black if I don’t delete the materials and components, then re-add the components. It is however a large composition.

I’m convinced this is a Skatter bug and will try taking it up with them. I’ve found another similar bug with Skatter not rendering compositions after using VRay lighting tools, so you need to delete and re-link the scatter hosts to get it to render again. Hella frustrating on a huge project where this takes 20+ minutes to fix.