A possible bug in the materials window


#1

In the materials window there is the option to purge unused materials, when i go to purge the unused ones that aren’t being used it won’t let me, it is grey and won’t let me click it, and there are times it will let me click it and purge the unused materials, and when i go to upload the model the purge unused materials window pops up and says do you want to purge unused materials and when click yes then all the unused materials are removed.


#2

It’s customary (essential) to post your operating system, SketchUp version and a model exhibiting the problem.


#3

I’m using windows 8.1 and sketchup make 2015, as for the model it does this thing with just about everything i make in sketch up.


#4

are they in your template? and/or set to style i.e. use material for edges?
groups can also have a color that hides if you add color inside the group…

just thoughts…
john


#5

The only materials that can be purged are the ones in the In Model tab (the little house icon). Materials in your material libraries cannot be purged.

Anssi


#6

They are in the in model tab.


#7

They aren’t in any template or anything like that, they are in the in model tab, and i had nothing grouped together that had that certain material in it.


#8

Any components in the component window?


#9

There are but the materials i’m trying to delete are not part of any component or group.


#10

It is rather odd.
Even Tig’s purge plugin won’t get rid of it.


I’ve added this simple model to see if anyone can find the yellow.
Unpurgable.skp (14.2 KB)


#11

@Box, The only way to purge that one is to use it first, then remove via materials window, replacing with default…

very odd, how was it added?

john


#12

Here you go, did it again so you can see there is nothing strange about the model or how I applied it.


#13

I think the reason the material cannot be purged is rather obvious.
It’s because the material is in use.

That is, it’s the active material in the Materials browser.
Click on the tiny Default Material swatch in the materials browser to shift focus … then try purging.


#14

D’oh
and 16 other letters


#15

That could be it then, there could also just be surfaces i painted that i can’t see because i covered it up too.


#16

The most common reason for a material to stick in the model is that some of the edges are painted with it. You won’t see it if you haven’t checked the By Material setting in the style edit window. A good FR might be to disable the painting of edges if this setting is not in use.

Anssi


#17

on my mac, I can only ‘Remove’ it, then it is ‘Purged’…

do you have ‘Remove’ on Windows…
john