(SOLVED) Undo not working SKP pro 2021

Hi. For a few days now undo in skp has stopped working. I can only do one single undo. This is regardless of what I want to undo or what tools or commands have been made. For example in a new model I draw three lines and do a Ctrl+Z or go to Edit/undo. One line disapears and then nothing.Then if I check under Edit the next undo showing there is “undo properties” and if I click that the next undo showing is “undo component”. Then it just cycles between those two. This is on my laptop which I dont use frequently so I cant quite remember which plugins I last installed. I tried disabling a few and to try to see if they where causing this but could not find a solution. I have googled allot but have not found anything for SKP pro 2021. Im at my wits end and can barely work. Any help much apreciated.

Try repairing the installation of SU2021. Find the downloaded installer, right click on it, choose Run as administrator, and then the Repair option when it is presented.

Thank you kindly DaveR. I just did what you suggested ( run as admin, repair) Did not fix the problem unfortunately.

Can you share an example model skp that encounters the problem so we can be completely sure it is not an issue there? Given that the repair installation made no difference, my only other guess would be an extension that is doing something in the background each time you add an edge.

I would try disabling all extensions in the Extension Manager. The restart SketchUp and try again. If Undo works again, add a few extensions and see what happens. Keep trying a few extensions at a time.

I will try that. thx…will report how it goes :slight_smile:

Good news. Undo works again after disabling all in extension manager. Am now slowly enabling one by one…

Culpit found. A extension called “Building Creator” by Neil Burkholder. Disabling it fixed my undo problem. Vaguely remember installing it but never got round to trying it properly.
Thank you DaveR. You are extremely helpful as always and saved my day and my current project.
pew! what a relief :slight_smile:

2 Likes

I sent Neil a message about this!

1 Like

I had a bug that was preventing undo from working in some situations. Needless to say, it was very annoying. The good news is that it is already fixed. Try installing the newest version from the Extension Warehouse.

https://extensions.sketchup.com/extension/4d1d4672-84d9-4117-a119-e5e502e09fa1/building-creator

1 Like