Problem with "undo" in SketchUp 2019

I have a problem with “Undo” in SketchUp Pro 2019 /Windows/. The function works only one step back. If I want to return 2 or more, doesn’t allow me. This is very unpleasant because “Undo” is a often used function at me.
The previous version didn’t have this problem.
What could be the reason?

It must be something you are doing or the way you are attempting to use Undo.

How are you accessing Undo? There haven’t been any changes to the way Undo works in SketchUp.

When you installed SketchUp 2019, did you do so correctly by right clicking on the installer and choosing Run as administrator from the Context menu?

Yes, I always installed this way. Тhe new license for version 2019 I have a week and the problem is from the beginning.

There are some posts from a few years ago in which others reported problems with Undo. It turned out in those cases that there was an extension that was using up the Undo stack. Do you have any extensions installed? If so, what are they?

Try disabling Brighter 3D and Curic Mirror, close and restart SketchUp and see if there’s a change. Of course Undo is only available for operations performed in the current session so you’ll need to do some things first so there’s something to undo.

It’s so unpleasant that the Uddo doesn’t work, I’m ready to reinstall everything. With “Brighter 3D” I working for years and I haven’t problems, but I had to go to a new version for 2019. “Curic Mirror” I can without it.
Apparently the problem is just for me. I will try what you have suggested and will report.

If you right-click on the SketchUp installer, and select Run as administrator, are you given the option to Repair or Remove? If so, can you select Repair and see if that fixes the problem?

If you open the Edit menu and look at its Undo entry, what operation name does it show?


If undoing is triggering an extension to make a change to the model, e.g. write an attribute, it could prevent you from undoing any further than that as each undo adds to the stack. Trying with extensions disabled as Dave says is a good way to identify the culprit.


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.