[SOLVED] Language file management issue

Hi there,
I installed the French Windows version of SU 2019, then decided to update an existing manual in English for version 2016. So, I removed SU 2019 Fr and installed SU 2019 En.
Surprize surprize, there is some French stuff left:


How come?
Is “Palette par défaut” good English? :slight_smile:
(like Voilà, Cul de sac and Bizarre…)

How did you remove?

Best practice:

Classic License:
Remove license, first ([menu]Help->Welcome to SketchUp and then click the remove license button in the classic license tab
Then run the installer and choose Remove

Log out, first, then run the installer and choose Uninstall

both by rightclicking on the installer fiel and choose: ‘Run as Administrator’

Then install the version of you liking (rightclick etc.)

There is some sort of hack that let’s you run both domestic and english version, you need to install the domestic language and run the english version by adding a parameter behind the exe- command.

It was the Trial version. Just did a Remove from the Programs and Functionalites control panel.

there are multiple locations on Windows:

The Local and roaming in the hidden AppData per user and in the (also) hidden ProgramData:

C:\ProgramData\SketchUp\SketchUp 2019

then there is also one in the Program Files:

C:\Program Files\SketchUp\SketchUp 2019

were you find the resources and files to use for your Manual:

C:\Program Files\SketchUp\SketchUp 2019\Resources\en-US

on a mac, no need to uninstall…

lang_dirs = Dir.glob('/Applications/SketchUp 2019/SketchUp.app/Contents/**/fr')
lang.dirs.each do |dir|
  File.rename(dir, dir + '_non')

## to restore 
lang_dirs = Dir.glob('/Applications/SketchUp 2019/SketchUp.app/Contents/**/fr_non')
lang_dirs.each do |dir|
  File.rename(dir, dir.sub(/_non/, ''))


there is also a styletemplatefile:

looks familiar?

if you edit that and save as version 6 file:

and open SketchUp again:

You will have a personal style…

1 Like

I removed the sw then deleted the two appdata hidden folders (in Local and in Roaming), then reinstalled the sw and now I do have “Default Tray” instead of “Palette par défaut”.
Topic closed for me.
Thanks to all.