French Welcome screen

I have downloaded the English version but my welcome screen is in French, how can I change that?

It shouldn’t be able to switch languages on you like that. My suggestion is to re-download and re-install the English version as (to my knowledge) there is no way to change it after install.

On Mac, there is no ‘language’ version, they are all in the installer. (That’s why it’s 8x bigger than the Windows installer)

It looks for the set language in the System settings.
So your’s has French higher than others.

You can set this for apps to behave differently.

This might come in play for multi language countries like Belgium or Canada😀


With SketchUp closed, go into the language System Preferences, Apps tab, and add SketchUp to the list. As you add it you choose which language you want it to be in.