Unable to change language back to english of Sketchup Pro 2018

languagehandler

#1

For some reason my Sketchup 2018 pro changed the language from english to swedish. I can’t get the english version back for the program.

This is so frustrating. I have set locattion to US and windows display language to English. Downloaded and installed the english version of SU over the old version but still it’s in swedish. How could I revert to English and have it stay that way.

This is so frustrating!!!



#2

SketchUp includes two languages: 1. the localized language which is loaded if it matches the system language, and 2. English (en-US) as fallback which is loaded if the system is set for example to another language (e.g. Swedish SketchUp on Portuguese OS). As far as I understand, after restarting Windows, the system language was loaded as English (en, en-GB or en-US), and so should SketchUp load English. I doubt SketchUp requires the OS to be set to US English, since there are British users (who have to cope with American English due to lack of translators).

You could:

  • Uninstall the Swedish version of SketchUp Pro and only install the English version.
  • You could edit the shortcut that launches SketchUp (right-click shortcut → Properties → target → append -lang=en-US after the executable path)

#3

Hello @stefan1

In searching the Help articles, this is all I find regarding language settings in SketchUp.

Changing SketchUp’s Language — SketchUp Help
https://help.sketchup.com/en/sketchup/setting-software-and-file-preferences#change-language


#4

Yes I found that as well. But my windows display language is not Swedish, yet I’m not able to use Sketchup in anything but Swedish. Also there is a problem with all of my keyboard shortcuts.

All keyboard shortcuts are gone, but if I try to reassign them I get this message to reassign to the same thing…


#5

one thing that comes in mind is the way you installed the English version.
I had a simular problem when installing a french version for testing purposes. Educational institute would like to give their students a choise: French or English.

The only thing that worked was:

To uninstall the priorly installed version (in my case EN, in your case Swedish): right click on the installer file and choose ‘Run as Administrator’, when prompted, choose ’ Uninstall’

Then run the installer file of the version that you would like (Rightclick, choose ‘Run as Administrator’)

In my case,I installed a French version and added -lang fr to the shortcut as @Aerilius explained.
I now have two shortcuts on my machine and can run both versions simultanously: