[SOLVED] Issues with Sketchup Pro 2019 activation

I just recently received my serial number and auth code for Sketchup Pro. (I am in a K-12 organization and we applied for a grant through TCEA and this is how the serial number and auth code were provided to me.

Using the documentation provided I am installing SketchupPro 2019.3 and copying over a activation_info.txt into the appropriate \ProgramData\SketchUp\SketchUp 2019 folder

Doing this the first time worked great! I opened it up and it showed a message that it was activated with a classic license for the next 2 years.

Issue:
On devices with 2018 previously installed, I am uninstalling and removing the files in ProgramData prior to installing 2019. After it is installed with the same method I was previously successful with, I get a error message that says “Oops… that doesn’t look like a valid serial number and authorization code…”

I verified again that the activation_info.txt holds the correct values, but I am unable to get it work. Help!

System:
Dell Optiplex 3020 w/ Intel HD Graphics 4600
8 GB RAM
Windows 10 x64 build 1803

be aware, that SketchUp license data is in general version specific, i.e. license data of version 2019 won’t run version 2018 (and older).

Reinstall version 2018, remove the license from “Help > License Management…” and try activating version 2019 than. If copying the license file still fails you can aways input the license data manually in the license dialog mentioned above.

2 Likes

A lot of times, the activation_info.txt file is actually named activation_info.txt.txt, the extra added extension causing activation to fail…
little duh-moments…

I am in the exact same situation here: K-12, got the license through our state. In this instance around 1/2 of a lab was able to activate (using the activation_info.txt method), while the other half gets the “doesn’t look like a valid serial number” message.

This is a lab of 30 machines, all deployed via the MSI method + copying the activation_info.txt file over. All of these machines had previously had Sketchup 2017 installed (using the PLTW license information), but that version was uninstalled and the machines rebooted before installing Sketchup Pro 2019.

I would love to know what is happening here.

Edit: I also tried manually copy-pasting the license information I received (that worked on some machines) into the manual “advanced” section of the license entry prompt - same error message.

I removed all files and folders from the ProgramData Sketchup directory except for the 2019 folder, and searched through the registry for any entries related to Sketchup and/or licensing information - nothing to note except for the standard extension registrations and such. I tried removing the existing .lic files (in case there were unknown issues) to no avail

What license did you receive exactly?
A Network or Laptop license?

The license I have received does not clarify what type it is. It says it is for Sketchup Pro 2019, with my name, seats, company, serial, auth code, and expiration date.

The program overview only states:
The SketchUp Statewide License Grant program provides free licenses of SketchUp Pro to public primary and secondary schools. Please be sure to keep all SketchUp grant license codes within your State Department of Education.

Would I possibly need a different installer depending on the license? I will be working on this some today to explore some of the suggestions above

1 Like

Thank you for the reminder, I am aware of it being version specific. I attempted to reinstall 2018 and it will no longer activate with my codes from last year. I am unable to get into License Management to attempt the suggestion above. When manually inputting the activation information into the application, for 2018 or 2019, it continues to fail with the same message in the original issue “Oops…etc etc”

Thank you for the tip, I double checked my activation_info file and it is correctly named without the 2 .txt’s on the end.

Digging in further, our TCEA representative initially asked me for our Public facing IP address. She informed me a change was made between 2018 and 2019, that we now have to register this with Trimble in order to fulfill the grant request.

I provided her 1 address and not a range. I am working to gather what the range is for our organization to have it resubmitted. The only common factor I can find between the ones that are working in my org and ones not working is that they have different public facing IP’s. All the ones working match the IP I submitted.

This was the solution!

I wrote back to our TCEA representative and provided our public facing ip address range. She quickly wrote back and added to the whitelisting.

I am now able to install using the same method as before with no issue activating at any of my campuses.

Thank you all for your time and ideas!