(SOLVED?) Errors, black screen when opening files in SketchUp Mobile Viewer (Caused by sketchy edges)

I’m trying to open files on the SketchUp Viewer mobile app, and most of the models I try to open return errors. One error is “There was an error opening this file. Please re-download this model and try again.”

Other times, I try to open a model, and I just get a black screen, no error.

I can see the layers in the model, so it seems to be opening it, but there’s just a black screen. Anyone else with this issue? I’ve got a Samsung S9+, running the latest version of the app.

Can you upload (here if not too large, or to a file sharing service like Dropbox or OneDrive, with a link here), at least a couple of the models which show this behaviour?

I have a similar phone (Samsung Note 9) and can try viewing them on that.

Are your models just too big for the phone viewer?

The more I play around with it, I discover it’s not really targeted to one model or the other. For example, it’s happening to me randomly with the sample Dance center model too. For example, I had the Dance Center opened for a while just fine, but then I went to open a new model, and the screen just went black. So then I tried to open the Dance Center again, and the screen is black again. But if I wait 5 minutes or so, I can suddenly open the Dance Center again…

Oh! I think I might have a hunch on what’s causing it.

I believe the error happens when trying to open a model that has been saved with a sketchy edge style active. Since the mobile viewer doesn’t support sketchy edges, it’s causing the app to get hung up.

Can anyone confirm what happens if you open a model that has a sketchy edge style active?

2 Likes

can you share a link to an example model to try with?

@Cotty I’ve just uploaded a model to the 3D Warehouse called ViewerTestSketchy. If you click the cloud icon > 3D Warehouse > Search button, and type that in, you should find it.

I’ve also attached the file here, if you find it easier to download to your phone directly.ViewerTestSketchy.skp (198.6 KB)

It’s just the default faceMe component, with a sketchy edge style active when saved. I just tested this on my phone, and as expected, I just get a black screen.

I can confirm the black screen on my phone (Android 9).

1 Like

Me, too!

I’m going to try a non-sketchy version now.

1 Like

Sketchy edges have a long history of being problematic even in the desktop version. Many graphic cards have had issues displaying them over the years. The most common one was they would render as very thick lines, sort of like drawing with a large blunt crayon when you wanted a sharp charcoal.

1 Like

New Aaron worked fine as downloaded, then failed (black screen) when I changed his style to a sketchy edge.

1 Like

@MikeTadros Have you seen this bug?

I don’t think the changes will affect the things you’re talking about, but the Android app has been updated three times this week. You might as well make sure you’re on 5.1.2.

@Matt the symptom has been reported before, but I think this is the first time we’ve had anyone put forward a hypothesis that traces the cause back to Sketchy Edges. We’ll investigate. Thanks for reporting! If this turns out to be the cause, a fix for it will help a lot of folks!

2 Likes

@colin Thanks for the suggestion. I updated the app a few days ago and I am indeed on 5.1.2

@MikeTadros That’s great to hear! Thanks.

I was using 5.1.3.