Solid tools trim subtract won't work on a specific component


#1

Hi
I’m still fairly new so please bear with me.
I’ve been using the solid tool trim and subtract to cut objects to length.
I have a model of a piece of sheet metal that I want to trim to length so I draw a rectangular cube that partially envelops the portion of the sheet metal that I want to remove/ trim away.
I select the cube and then the sheet metal and nothing happens.
But now If I do a subtract the first entity selected disappears but the remaining entity is whole???.
I can make the trim and subtract work on the plywood entity below the sheet metal.
I checked the entity info dialog to see it the component was locked or somehow was protected but nothing leapt out at me.
I’m not sure what is going wrong but with out some status message I don’t know how to diagnose the trouble.
How can I work out what is special about this particular component that prevents the solid tools from doing their duty?
thanks in advance


#2

If you post your model, someone will be able to answer!


#3

… metal sheet…
Is one of the ‘future’ edges created by the tool operation going to be very short?
Then SketchUp may have problems to perform the operation.
As Steve mentioned, upload the model please.


#4

Extension_Cord_Shed_old_school_003.skp (765.6 KB)


#5

I have placed a piece of sheet metal on the roof?
I’m trying to trim it to the edge of the plywood.
Does that make sense?


#6

Your sheetmetal is only 0.02147" thick. As @Wo3Dan noted, most likely SketchUp is unable to create the necessary edges in something so thin. You could try scaling up the relevant parts, doing the operation on the enlarged copies, and then scaling back down.


#7

It has been working fine all the other pieces of metal are cut to length using this method.
Look at the rafters and where the doors will go I used the trim to cut these features in the metal that all went fine.


#8

The need for tiny edges depends on the specific orientation of the parts. It might happen only in certain cases. If you try the scaling and it works, that is your proof.


#9

Also, your metal is not quite flat to the roof, it has a gap at the rear. See attached. That may be adding to the issue.


#10

Hi
Which brings up another issue that you might help me understand.
When I use the protractor and the tape measure I get something like this ~ 18.4 degrees.
ummm umm the reason I’m using CAD is so that I can build things with complete precision???
Why the hand grenades and horse shoes when it comes to measurements?
How to I increase the accuracy of my measurements?
So when I rotate something it matches what I measured exactly and doesn’t leave a small gap at the end?

The rectangular solid completely envelops the metal it is not the ply wood (but thanks for pointing it out the gap I want to fix that).
What does the plywood which is not the metal and not the cutting solid have to do with anything?


#11

As an alternative attack, try this: instead of using the solid tools, use intersect faces as follows:

  • Open your cube and copy the face that will cut the roof.
  • Close the cube and move it aside
  • Open the roof sheetmetal component and do Edit->Paste In Place to get a copy of the face from the cube inside the sheetmetal component
  • select the face, right-click and choose Intersect Faces->with context
  • delete the part of the sheetmetal beyond the edge of the roof and delete the cutting face
  • trace one of the ends with the line tool to close the end face of the sheetmetal

Sometimes the solids tools get overwhelmed by subtle things and fail to work.


#12

You can increase the precision of the angle readout in the units panel of the model info window. But, to avoid things like that little gap, you need to pay attention to the snap hints given by the inference engine. In this case, you should have been able to get inference points at both corners of the plywood. Almost all tiny model errors of that sort result from not “listening to” the inference engine.


#13

Hi slbaumgartner
I tired that tack but I could get a inference so I punted and measured the angle (with the ole approximate result) then rotated to that angle.
It bothered me at the time but I was frustrated and gave up too soon obviously.
I’ll re do it and so if I can make the snap happen.


#14

For kicks, I tried rotating the sheetmetal down to the plywood. I had no problems getting inference points. So, don’t get discouraged, just keep trying :wink:


#15

Hi slbaumgartner
Umm so what you are saying is forget the cube.
I draw the face and then push pull into a rectangular cube and use the solid tools

Your saying just draw the face.
Copy the face.
Select the component.
Edit the group/
Paste the face in place.select the face, right-click and choose Intersect Faces->with contextSelect the face and Faces->with context
Then start erasing lines till I’m left with what I want.
Which worked!!!
It was a little disconcerting I erased the face first but there was a grey rectangle in its place till I erased the perimeter lines of the face.
I’m sure glad I paid 500 bucks for the pro with the solid tools.
Thanks to everyone again
Now I have to get the rotate snap to work.


#16

The solid tools aren’t perfect. When they work, they can save steps. When they glitch, they can leave you very frustrated.


#17

The ‘Rotate’ tool snaps to target endpoints.
Only when the rotated edge’s endpoint is in the same context as the target edge (plus its endpoint) will it snap to this target edge. (improvement since SketchUp 2015).

Also it might help to switch face style to X-Ray to be able to see the target endpoint through obstructing faces of the rotated selection.


#18

Hi Wo3Dan
I’m struggling mightily to rotate my sheet metal.
the trouble is that the sheet metal’s faces/surfaces are not perpendicular or parallel to the plywood on my roof.
I can stick my sheet metal on the sides of my building but no joy when trying to rotate and stick it to the roof.
I’ve attached the drawing.
I’m sure this is no big deal but it is with my level of Extension_Cord_Shed_old_school_004.skp (684.3 KB) experience


#19

Hi slbaumgartner
I am losing my mind trying to get the sheet metal to rotate down to the plywood.
The protractor wants to align to the surfaces of the metal none of which are perpendicular to the red axis (I need to rotate about the red axis parallel to the plywood).
There must be some magic to it.
I’ve been trying for an hour with no joy.


#20

See if any of this helps.

Shep