Trimming problem


My first post and first major problem.
Been working with SU for years and never really had any problem I couldn’t solve.

I’ve encountered a problem with the solid tools.
I did the following:
Made two solids.
Select trim tool.
Select first solid.
Select second solid.

Sketchup does nothing for a few seconds.
And than it removes almost my entire second solid. Even the part that didn’t intersect!
I pressed Ctrl+Z to undo the trouble.
Moved the second object a bit.
Tried again.
This time nothing seems to have happend.
But when I selected the object both were not solids anymore.
Pressed Ctrl+Z again to undo the mess.

profiel T boom|690x377

I now this doesn’t seem that complicated but I can’t show any details.
I had to import my CAD drawing scaled up (x1000).

I checked the following:

  • I have two solids to trim
  • I tried to trim two other solid (two cubes), this worked perfectly.

What can I try next?


Next thing is to share the file!?

I suspect that the Trim operation creates small edges in its result.

I can’t share files yet and I’m not allowed to either.
So I have to try and fix this myself.

If the trim operation creates small edges, how do I fix this?

It is quite possible to make two solids that subtract to give a non-solid result.
This is because the intersection process can involve tiny edges…
SketchUp regards points closer that 1/1000" apart as coincident and ignores the very tiny edge that would result, as a consequence the faces supported by that missing edge are also skipped, leaving a ‘hole’ in the surface and thereby zero volume for the now non-manifold geometry.

If the CAD imports are drawn to a ridiculous level of detail then their tiny edges could well be causing you this grief !

Two workarounds…

  1. Draw over the CAD profile with a simplified form for the geometry, that extrudes and intersects better.
    Do you really need every little radius, notch and so on ?

  2. Make your geometry much bigger - I see you scaled your CAD info x1000, but if you scale up the SketchUp objects by x1000 or more then the tiny geometry might be large enough to intersect and give a solid… Search here for the “Dave Method” which involves making a pair of components, scaling one up enormously, editing that, then doing the operation inside its entities-context; when you are done the small [originally sized version] will display the hoped for changes too, and then you can delete the giant-version.
    Tiny geometry can exist in SketchUp but it cannot be created directly !

1 Like

Thank you for your respons.
I actually managed to do it before in a previous drawing with a similar setup.
I will try to enlarge it a bit more.

I first imported the .dwg
Then I made my solid.
I scaled it down.
And ran in a few non solid issues.
Fix those so I had perfect solids.
And then tried to trim.
Enlarged the whole thing.
Tried to trim again.
Didn’t work.

So I’ll try and enlarge a bit more.

I would say this time you may have selected the components in the incorrect order for your intention.

This is more likely to have the intended result, to see it you may be able to use x ray or move one of the components temporarily or make a copy. But the scaling issue still remains as the components are no longer solid. The Dave Method mentioned earlier should take care of that.

With the native Solid Tools be sure to select the “cutter” first, then the component to be cut. Think “use this to cut that”.

Sidenote if using components: The downfall of the native Solid Tools is that the component you cut will be made unique and may lose it’s important link to any other components of the same definition you have in the model. The extension “Eneroth Solid Tools” takes care of that by retaining the component definition. But that Trim Tool works in the reverse order of “cut this with that”.

I scaled it up a bit and replaced the first solid with a simple square.